NVP-vProxy: New vProxy registration in the NMC fails to open the lockbox

Summary: During the registration process of a newly deployed NetWorker VMware Protection (NVP) vProxy appliance, the registration fails with error "Failed to open lockbox."

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Symptoms

The NetWorker VMware Protection integration is being configured with the vProxy Appliance. The vProxy has been deployed, and the new NSR VMware Proxy resource is being added in the NetWorker Management Console (NMC) under the Devices tab. The appropriate details are configured for the NSR VMware Proxy resource and when selecting the "OK" option, an error message is generated:
 
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Failed to open lockbox C:\Program Files\EMC NetWorker\nsr\lockbox\[NETWORKER_SERVER_FQDN]\clb.lb
The /nsr/logs/daemon.raw shows:
MM/DD/YYYY [NETWORKER_SERVER] nsrd NSR notice vProxy '[NSR_VMWARE_PROXY]' is now Enabled. 
MM/DD/YYYY [NETWORKER_SERVER] nsrd NSR info VM proxy Warning event: vProxy '[NSR_VMWARE_PROXY]' is unavailable. 
MM/DD/YYYY [NETWORKER_SERVER] nsrmon NSR critical Unable to retrieve vProxy '[NSR_VMWARE_PROXY]' connection information. 
MM/DD/YYYY [NETWORKER_SERVER] nsrd NSR error Instance UUID not found for '[NSR_VMWARE_PROXY]' vProxy.

NetWorker: How to use nsr_render_log

Cause

There is an issue with the lockbox's clb.lb file. It is either corrupted or non-existent.

Resolution

If the lockbox files do not exist. Create a new lockbox file as per the NetWorker Security Configuration Guide.

If the lockbox files are present in the location of the error message, the lockbox files should be re-created in the environment. The following procedure may be used to re-create the NetWorker server "clb.lb" lockbox files:
 
  1. Open the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI).
  2. Select the Server tab.
  3. Select the Lockboxes tab.
  4. The details pane shows a lockbox for the NetWorker server fully qualified domain name (FQDN).
  5. Create a new lockbox using the short name of the NetWorker Server.
  6. Shut down the NetWorker Server services:
Linux: nsr_shutdown
Windows: net stop nsrexecd /y
  1. Make a backup copy of the NetWorker server lockbox FQDN folder content:
Default Linux location:  /nsr/lockbox/[NETWORKER_SERVER_FQDN]
Default Windows location: C:\Program Files\EMC NetWorker\nsr\lockbox\[NETWORKER_SERVER_FQDN]\
  1. Delete the contents of the original FQDN lockbox folder.
  2. Copy the lockbox files from the NetWorker server lockbox short name folder to the NetWorker server lockbox FQDN name folder.
  3. Delete the folder for the NetWorker Server lockbox short name. 
  4. Start the NetWorker Server services.
Linux: systemctl start networker
Windows:
net start nsrd
If NMC is installed on the NetWorker server: net start gstd
  1. Log in to the NMC or NWUI and register the vProxy.

Additional Information

When using NetWorker 19.10 with unsupported Red Hat Enterprise Linux version 9.2, this resolution fails with error "The lockbox or cryptography library could not be found." 

Upgrade to NetWorker version 19.11 which supports Red Hat Enterprise Linux version 9.2 resolves the issue.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000032274
Article Type: Solution
Last Modified: 12 Sept 2024
Version:  5
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