NetWorker. NMC Monitoring отображает состояние «Никогда не запускается» для политик, а при нажатии на состояние рабочего процесса отображается сообщение «Шина сообщений не может открыть подключение сокета».

Summary: NetWorker. Если брандмауэр блокирует порт 5672, NMC Monitoring отображает состояние «Никогда не запускается» для политик и при нажатии на состояние рабочего процесса выдвигается сообщение «Message bus unable to open socket connection to host» ' on port 5672: request timed out» ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • В окне мониторинга консоли netWorker Management Console (NMC) отображаются все политики «Никогда image.pngне запускаются», однако задания резервного копирования и клонирования завершаются в соответствии с расписанием.
  • При попытке открыть свойства рабочего процесса/действия в NMC появляется следующая ошибка:
Шине сообщений не удается открыть подключение сокета к хосту «Networkerserver_hostname» на порте 5672: произошла ошибка разъема
image.png
  • NetWorker Server версии 19.5 или более ранней. Порт 5672 — это порт без SSL, используемый при обработке очереди сообщений. В более новых версиях NetWorker используется SSL-порт 5671. 

Cause

Брандмауэр блокирует порт 5671

Resolution

NetWorker. Как отключить порт 5672 для DSA-2018-120, чтобы программа сканирования по-прежнему не отображала уязвимость

Откройте порт 5671 на операционной системе сервера NetWorker или сетевом брандмауэре. Когда брандмауэр разрешит этот порт, NMC отобразит правильную информацию в окне Мониторинга.

Процессы и порты

NetWorkerПорт 5671 используется процессом rabbitmq на сервере NetWorker. Процессы NetWorker используют этот порт/службу для передачи информации друг между другом и их предоставления в пользовательских интерфейсах NetWorker. 

См. инструкции вендора операционной системы по созданию правил брандмауэра. эти изменения должны быть внесены системным администратором/администратором безопасности. После внесения изменений в брандмауэр операционной системы убедитесь, что порт 5672 успешно подключен между сервером NetWorker и сервером NMC. Если подключение по-прежнему завершается сбоем, убедитесь, что сетевой брандмауэр не блокирует связь. 

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker, NetWorker Series, NetWorker Management Console
Article Properties
Article Number: 000028146
Article Type: Solution
Last Modified: 13 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.