Falha nos backups de VM com erros de log-in no vCenter

Summary: Os backups estão falhando ao usar regras ou tags.

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Symptoms

Os backups de VM que estão usando regras ou tags estão falhando.
Backups regulares concluídos - selecionados usando a política

Os logs mostram o seguinte erro:

Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 224276
libCURL SSL support is Enabled.
Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCenter_server.FQN.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.

E:

NWSERVERNAME nsrdisp_nwbg NSR critical Inventory session status returned with a failure. Error: 'Failed to load inventory from 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.'.
lNWSERVERNAME nsrdisp_nwbg NSR notice
Reading the XML from RAP without running nsrvim again

 

Cause

O usuário, a senha ou ambos foram alterados para backup de VM.

O nsrvisd está usando a senha.
A alteração nunca se refletiu no processo de inventário do nsrvisd.

Analise os log-in:
/nsr/vproxy/logs/nsrvisd
Ou
/opt/nsr/vproxy/logs/nsrvisd

O registro reflete o usuário antigo - a senha deve ser criptografada.

Resource Definition: {"Config":{"SessionId":"92-23993-9966cdbbd1","LogTag":"@(#) Build number: 41","LogLevel":"INFO","IdleTimeout":0,"AcceptedLanguage":"","VimServer":{"HostName":"VCENTER_SERVER","TcpPort":443,"UserName":"administrator@vsphere.local","UserPassword":"********","ThumbPrint":"","HypervisorMode":"vSphere"},"RefreshInventory":10},"Actions":{"ChangeSession":"/api/v1/InventorySessions/92fba-7a3a-48eb-84-e706cdbbd1","DeleteSession":"/api/v1/InventorySessions/92fbeef3a-48eb-84a6-70736cdbbd1","CancelActivity":"/api/v1/InventorySessions/92fbeefa-7a3a-48eb-84a6-e70736cdbbd1/activity","GetSession":"/api/v1/InventorySessions/92fbe

 

Resolution

Esse é um problema, a investigação de engenharia da Dell está em andamento.

A solução temporária é limpar o arquivo de estado - InventorySessions.gob

O arquivo de estado pode ser localizado em.
/nsr/vproxy/logs/nsrvisd/InventorySessions.gob
OU
/opt/nsr/vproxy/logs/nsrvisd/InventorySessions.gob

Renomeie InventorySessions.gob.
mv InventorySessions.gob InventorySessions.gob_old

Pare nsrvisd - usando matar.

ps -eaf | grep nsrvisd
kill <pid>

O NSRVISD é reiniciado.
Verifique se a reinicialização ocorreu:

ps -eaf | grep nsrvisd

 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000056263
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  4
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