Article Number: 000125902


Dell Migrate

Summary: Dell Migration and Erase process using SupportAssist.

Article Content


Symptoms
This article covers steps to perform Dell Migration and Erase process using SupportAssist.
Cause
NOTE: Ensure the following prerequisites are met on both old and new PCs before initiating the Dell Migrate process.
  • You must be signed in as an Admin on both PCs to perform Dell migration as it requires advanced permissions to perform migration functions on your PC.
  • Both PCs are required to be connected to the same network.
  • Also, both PCs should be connected to AC power.
  • Ensure no other applications are in use or open.
  • Additional prerequisites
Resolution

Dell Migration and Erase Process

  1. Launch the Dell SupportAssist application on your new Dell PC from the start menu by searching for SupportAssist.
 
NOTE: If it is not installed on your PC, you can download SupportAssist and install it: Download SupportAssist

 

  1. On the new PC, click Yes on the green banner ‘Would you like to start using Dell Migrate?’.
    You can also click Go now at the bottom left under Dell Migrate (Figure 1).
New PC (Launching SupportAssist)

Figure 1 – New PC (Launching SupportAssist)

 

  1. On the next screen, you will see the welcome page for Dell Migrate. Click Let’s get started to begin connecting both PCs (Figure 2).
 
NOTE: Click Terms and conditions to review the service contract.
New PC (Dell Migrate Welcome Screen)

Figure 2 – New PC (Dell Migrate Welcome Screen)

 

  1. It will begin to validate the pre-requisites for connecting both PCs (Figure 3).
New PC (Running Pre-checks for Dell Migrate)

Figure 3 – New PC (Running Pre-checks for Dell Migrate)

 

  1. In order to securely connect the PCs, you must be on a trusted network. In the event that you’re on a network that you haven’t already classified as trusted within Windows on your new PC, you may receive the prompt below (Figure 4).
    You may click on Trust Network if you recognize the network.
    If you do not trust the network, we recommend you click Cancel and reconnect to a network that you trust and restart the process.
    If your network is already trusted, you will not see this prompt.
New PC (Trust Network)

Figure 4 - New PC (Trust Network)

 

  1. A new screen opens with instructions to download Dell Data Assistant on your Old PC (Figure 5). Follow these instructions in sequence.
New PC (Steps to follow on Old PC)

Figure 5 - New PC (Steps to follow on Old PC)

 

  1. On your Old PC, open a browser and navigate to Dell.com/DataAssistant to download the file.
    Once downloaded, run Dell Data Assistant from your browser’s Downloads bar or by navigating to the downloaded folder on your PC (Figure 6).
Old PC (Download and run Dell Data Assistant.exe)

Figure 6 – Old PC (Download and run Dell Data Assistant.exe)

 

  1. The Dell Data Assistant will run the required pre-checks on the PC and will prompt you if any of the pre-requisites could not be met.
Dell Data Assistant on Old PC

Figure 7 – Dell Data Assistant on Old PC

 

  1. On your Old PC, you might see a prompt for untrusted network (Figure 8).
    You may click on Trust Network if you recognize the network.
    If you do not trust the network, we recommend you click Cancel and reconnect to a network that you trust and restart the process.
Old PC (Trust Network)

Figure 8 - Old PC (Trust Network)

 

  1. On the next screen, you will see the welcome page for Dell Migrate. Click Let’s get started to begin connecting the two PCs (Figure 9).
Old PC (Welcome Screen)

Figure 9 - Old PC (Welcome Screen)

 

  1. On the next screen, the Dell Data Assistant will show the steps to be followed on both PCs to connect them (Figure 10).
Old PC (Discovering the PCs)

Figure 10 - Old PC (Discovering the PCs)

 

  1. Once the Dell Data Assistant identifies the new PC on the network, it will generate a verification code. This verification code needs to be entered on the new PC for secure data migration as shown below (Figure 11).
Old PC (Code display)

Figure 11 - Old PC (Code display)

 

  1. Once paired, a green verification code will be shown on both PCs (Figure 12).
    It is important that both the PCs remain connected to the same network throughout the migration process. Any issues while connecting the two PCs will lead to stopping the migration process.
Old PC (PCs connected successfully)

Figure 12 - Old PC (PCs connected successfully)

 

  1. If the Windows user profiles on the two PCs do not match, a pop-up screen will appear on the screen to confirm that you have used the right user profiles while starting the migration process (Figure 13).
    You may choose to continue or log off and login to the windows user profile that matches on both the PCs. If the user profiles are the same, it will skip to the next step.
    To know more about how to migrate multiple user accounts using Dell Data Assistant, refer to Multiple User Account Migration.
New PC (User accounts do not match on Old PC and New PC)

Figure 13 - New PC (User accounts do not match on Old PC and New PC)

 

  1. Once both the PCs are paired successfully, it will start to search on the old PC for the files and settings to be migrated from the old PC to the new PC (Figure 14a and 14b).
WARNING: Now on the old PC you will also be presented an Erase This PC button. Only click on the Erase This PC button once all your data is migrated successfully.
New PC (Searching for Files and Settings on Old PC)

Figure 14a - New PC (Searching for Files and Settings on Old PC)

 

Old PC (Searching for Files and Settings)

Figure 14b - Old PC (Searching for Files and Settings)

 

  1. The PCs are now ready to begin with the migration and you will be presented with 2 options (Figure 15);
    • Move everything for me option will move all user settings and user files from old to new PC.
    • Let me choose what to move option lets you select what user settings and user files you would want to move instead of moving everything from old PC to new PC.
New PC (Select Files to Migrate)

Figure 15 - New PC (Select Files to Migrate)

 

  1. Once the old PC has finished scanning the files and settings to migrate, it comes up with a ready to migrate screen message. Once this message is displayed, the data transfer is ready to begin. (Figure 16)
Old PC (Ready to Migrate)

Figure 16 - Old PC (Ready to Migrate)

 

  1. On the New PC, you can do a custom selection of the settings and files to be migrated from your Old PC to New PC. After selection of files for migration, click on Migrate Now to begin the data transfer (Figure 17).
    If you have multiple drives on your old and/or new PC, you may change the mappings of the drives between the old and the new PC by clicking Change under Files and settings will be saved to.
New PC (Migrate Now – Custom selection)

Figure 17 - New PC (Migrate Now – Custom selection)

 

  1. When you click on Migrate now, the new PC displays the progress of the migration (Figure 18a), while the old PC displays a message, “we are migrating your data now” (Figure 18b).
    The time it takes to complete a migration will depend on the network speed and the amount of data selected.
New PC (Migration in Progress)

Figure 18a - New PC (Migration in Progress)

 

Old PC (Migration in Progress)

Figure 18b - Old PC (Migration in Progress)

 

  1. When the migration is completed, the new PC displays the migration summary of files and settings that are migrated from old to the new PC. Click on Finish to complete the Migration (Figure 19a). The details of the entire migration can be seen by clicking the view details options on the summary screen (Figure 19b).
New PC (Migration Summary)

Figure 19a - New PC (Migration Summary)

New PC (Details for Files/Settings Migrated from Old PC)

Figure 19b - New PC (Details for Files/Settings Migrated from Old PC)

 

  1. With this, the migration from old to new PC is now complete (Figure 20). You can also erase your data from the old PC after you have completed your migration. Let’s discuss the erase process in the next steps.
New PC (Migration Completed)

Figure 20 - New PC (Migration Completed)

 

  1. Erase This PC helps to remove the user data from the old PC after the migration is completed, while retaining the Windows installation.
    On the old PC, once the migration completed message is displayed, click on Erase This PC to begin with the removal of the data from the old PC (Figure 21).
 
NOTE: The erase feature can be used on the old PC only once your new Dell PC and old PC have connected to each other at least one time.
Old PC (Migration Completed)

Figure 21 - Old PC (Migration Completed)

 

  1. This next step will check the pre-requisites for the PC erase to begin (Figure 22).
    Additionally, it will also check if the latest version of Dell SupportAssist OS Recovery is installed on your old PC. If everything checks out, it will proceed to the next step.
Old PC (Running Pre-checks for Erase)

Figure 22 - Old PC (Running Pre-checks for Erase)

 

  1. If your old PC does not have the latest version of Dell SupportAssist OS Recovery installed, it will show you option to use Windows Reset instead. Click on Launch Windows Reset when the application displays the We are ready to reset this PC on the next screen as shown below.
    Follow the instructions on the screen for completing the erase operation on the old PC (Figure 23). This will follow the Windows PC Reset procedure.
Old PC (Erase - Dell OS Recvery not present)

Figure 23 - Old PC (Erase - Dell OS Recovery not present)

 

Note that selecting Launch Windows Reset will initiate the Windows PC Reset, and it will provide the following two options. Based on the option we select, Windows Reset will start, and will take some time to complete depending on the number of files on the PC.

  • Keep my files - Removes apps and settings but keeps your personal files
  • Remove everything - Removes apps, settings and personal files too

To remove all your personal files, you may choose the ‘Remove everything’ option.
Additionally, you can also set a reminder for the Dell Data Assistant to remind you for erasing data from your Old PC as per your convenience.

 

Refer to the respective links for more information on Windows reset procedure for Windows 10 and Windows 8/8.1 respectively.

 

  1. If your old PC has the latest version of Dell SupportAssist OS Recovery installed, click on Reboot to begin Dell Migrate (Figure 24) and follow the instructions on your screen. For step by step instructions, please refer to SupportAssist OS recovery.
Old PC (Erase - Dell OS Recvery present)

Figure 24 - Old PC (Erase - Dell OS Recovery present)


Article Properties


Product

SupportAssist, SupportAssist for Home PCs

Last Published Date

07 May 2021

Version

9

Article Type

Solution

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