Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

How to Troubleshoot a RAID Hard Drive issue on a Dell PC

Summary: This article provides information on how to identify and resolve issues with RAID on a Dell Desktop system.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

If your system is experiencing issues with RAID like RAID error messages like RAID degraded or RAID failed, system configured with RAID is not booting into the operating system, rebuilding the RAID array, follow the instructions in this article.

Note: If you are having trouble booting with a PCIe RAID card installed. Please ensure you are on the latest revision of your Dell BIOS. Boot issues with older BIOS revisions have been reported.

Table of Contents:

  1. How to Troubleshoot a RAID configuration issue on a Dell PC
  2. Initial Troubleshooting
  3. RAID Failed
  4. RAID Degraded
  5. Deleting RAID
  6. Resetting to NON-RAID

Cause

Issues with RAID could be due to RAID not supported on your computer, RAID configuration settings in the BIOS, potential hard disk failure, or settings on applications like Intel Matrix Storage Manager and so on.

Resolution

Initial Troubleshooting

 

  1. Do you have RAID configured on your Hard Drives?

    1. Yes, then please proceed to the next step.

    2. No, then please go to the guide below :

  2. Are you getting an error before the RAID screen loads?

    1. Are you getting a blank screen with a flashing cursor? Go to this guide :

    2. An onscreen Start up error? Go to this guide :

    3. Is the system failing to POST? Go to this guide :

    4. No, then proceed to the next step.

  3. Have you run the onboard diagnostics?

    1. They wouldn't run, go to step 4.

    2. They ran and passed, go to step 5.

    3. They ran and failed with an error code, please go to this guide :

  4. If the diagnostics don't run then the system is failing at a point before the RAID is in effect. Please go to this guide for help in troubleshooting this issue :

Note: If you are troubleshooting a NO POST issue and are asked to remove the I/O Panel and the CMOS battery as part of identifying the NO POST fault, please be aware when the No POST issue is resolved you will have lost your RAID array as a result of doing this step.
 
Note: Please be aware resetting the BIOS to defaults can have the same effect.
 
  1. Are you having power issues and losing the date and time?

    1. Yes, you will need to troubleshoot the motherboard, the CMOS battery and your Power socket. The type of RAID running on these systems does not have a dedicated RAID card to keep the RAID volume up when there are system issues. If the motherboard or CMOS battery are failing they will take your RAID volume with them. I would advise contacting your Technical Support for further help with this.

    2. No, in this case please proceed to the next step.

  2. What type of RAID issue are you experiencing?

    1. A RAID Failed error message after POST? Go to section 3.

    2. A RAID Degraded error message after POST? Go to section 4.

    3. Are you looking to Delete a RAID Volume? Go to section 5.

    4. Are you looking to reset the Hard Drives to Non-RAID? Go to section 6.


Back to Top


 

RAID Failed

 

RAID 0 Failed
  1. If a RAID 0 Stripe volume fails you will get the error message shown below. The message gives the status of the volume and identifies any hard drive the system can see. The example shows that the only hard drive seen is on Port 0. That means you would troubleshoot the hard drive on Port 2. Knowing which port is faulty lets you know which drive inside the system is having the issue.

  • Intel(R) Matrix Storage Manager option ROM v5.0.0.1032 ICHx Copyright(C) 2003-05 Intel Corporation. All Rights Reserved.

  • RAID Volumes:
    ID Name Level Strip Size Status Bootable
    0 Volume0 RAID0(Stripe) 128KB 223.6GB Failed No
  • Physical Disks:
    Port Drive Model Serial # Size Type/Status(Vol ID)
    0 SAMSUNG HM120JI S09GJ10L209832 111.8.GB Member Disk(0)
  • Press <CTRL-I> to enter Configuration Utility..

  1. Having already run the Diagnostics and had everything pass, means that either the Hard Drive isn't being detected to have the diagnostics run or it is the controller and software on the drive that is faulty. I would recommend checking inside the machine that the power and data cables are securely fitted to the drive. Does this change what's reported?

    1. Yes, try booting and see if this has resolved your problem. If not you're looking at recreating the RAID array from the beginning as above.

    2. No, then I'm afraid you're going to have to recreate the RAID array from the beginning. You can find a guide below. If that doesn't resolve the issue then you will need to contact your Technical Support for further help.

Note: Data cannot be recovered from a RAID 0 failure.
 


Back to Top


 

RAID Degraded

 

RAID 1 Degraded

Visible from the Matrix ROM Option

  1. If a RAID 1 Mirror volume has a degraded status it will show the error message in the picture below. One of the two Hard Drives cannot be seen by the system and may have failed. The system then proceeds to boot normally on the remaining drive after that screen closes.

    1. If the onboard diagnostics passed you will want to troubleshoot how the RAID sees the degraded drive. Go to step 2.

    2. If they failed and you have the new Hard Drive you will want to go to Rebuilding RAID1.

  • Intel(R) Matrix Storage Manager option ROM v5.0.0.1032 ICHx Copyright(C) 2003-05 Intel Corporation. All Rights Reserved.

  • RAID Volumes:
    ID Name Level Strip Size Status Bootable
    0 Volume0 RAID1(Mirror) 128KB 223.6GB Degraded No
  • Physical Disks:
    Port Drive Model Serial # Size Type/Status(Vol ID)
    0 SAMSUNG HM120JI S09GJ10L209832 111.8.GB Member Disk(0)
  • Press <CTRL-I> to enter Configuration Utility..

 
Note: In a RAID 1 configuration, the system can continue to operate normally on the remaining drive. However, no redundancy is in place and any further data loss cannot be recovered until the array is rebuilt.
 
  1. The example in the picture above shows the only Hard Drive seen is on Port 0. That means we would look to troubleshoot the hard drive located on Port 2. I would check that the Power and data cable are fully seated does that resolve the issue?

    1. Yes, go to Rebuilding RAID1 in the next tab (Using the Intel Matrix Manager in the OS).

    2. No, continue to next step.

  2. Disconnect the degraded Hard Drive and turn the system on with it removed. Once the system boots, shut it down normally and reconnect the Hard Drive. Boot the system and go to Rebuilding RAID1 in the next tab (Using the Intel Matrix Manager in the OS). Did this work?

    1. Yes, your issue is resolved.

    2. Update the Intel Matrix Software and try again, if it still doesn't work, contact your Technical Support for further help. They may look to substitute a known good working Hard Drive into the system to confirm issue isn't with the cables or port on the Motherboard.

Note: If the hard drive has failed but is passing the diagnostics be sure to identify to your Technical Support which port the bad hard drive is located on.
 

Using the Intel Matrix Manager in the Operating System

Rebuilding RAID1
  1. You can manually rebuild the computer's redundancy mirror to the Hard Drive by Clicking the Start button.

  2. Go to All Programs\Intel Matrix Storage Manager\Intel Matrix Storage Console to launch the Intel Storage Console.

  3. Right-click the available hard drive on which to rebuild the RAID 1 volume and click Rebuild to this Disk.

  4. The computer can be used normally while it is rebuilding the RAID 1 volume.


Back to Top


 

Deleting RAID

 

Deleting a RAID Volume

Using Optional Matrix ROM

Note: When performing this operation, all data on the RAID drives is lost.
 
Note: For RAID 0 only: If the computer currently boots to RAID and the RAID volume is deleted in the Intel RAID Option ROM utility, the computer becomes unbootable.
 
  1. Press the Ctrl + I keys together when prompted to enter the Intel RAID Option ROM utility.

  2. Highlight Delete RAID Volume and press ENTER.

  3. Highlight the RAID volume to be deleted and press Delete.

  4. Press the y key to confirm the deletion of the RAID volume.

  5. Press the Esc key to exit the Intel RAID Option ROM utility.

Using Intel Matrix Storage Manager

Note: This procedure deletes the RAID1 volume and splits the volume into two NON-RAID Hard Drives with a partition. This process leaves any existing data files intact.
 
  1. Click the Start button and go to All Programs\Intel Matrix Storage Manager\Intel Matrix Storage Console to launch the Intel Storage Console.

  2. Right-click the Volume icon of the RAID volume to be deleted and select Delete Volume.

  3. On the Delete RAID Volume Wizard screen, click Next.

  4. Highlight the RAID volume to be deleted in the Available box.

  5. Click the right-arrow cursor/key to move the highlighted RAID volume into the Selected box and Click Next.

  6. Click Finish to delete the volume.


Back to Top


 

Resetting to NON-RAID

 

Reset the RAID Disks to NON-RAID
Note: When performing this operation, all data on the RAID drives is lost.
  1. Press the Ctrl + i keys when prompted to enter the Intel RAID Option ROM utility.

  2. Highlight Reset Disks to Non-RAID and press the ENTER key.

  3. Highlight the RAID volume to be reset and press the Space key to select the disks.

  4. Press the ENTER key to complete the selection.

  5. Press the y key to confirm the reset.


Back to Top


If you require further assistance, please contact technical Support.
  Contact Us  

Article Properties


Affected Product

Desktops & All-in-Ones, Fixed Workstations

Last Published Date

10 Apr 2021

Version

6

Article Type

Solution