Slik gjenoppretter du DELL EMC Networking N2000 og N3000 fra inkonsekvent tilstand under nedgradering av fastvare
Summary: Slik gjenoppretter du DELL EMC Networking N2000 og N3000 fra inkonsekvent tilstand under nedgradering av fastvare
Symptoms
Denne artikkelen forklarer hvordan du gjenoppretter svitsjen fra inkonsekvent tilstand mens du nedgraderer fastvareversjonen i Dell N2000 og N3000.
Krav
Konsolltilgang til svitsjen er et must. Du trenger fysisk tilgang til porten til svitsjkonsollen for å fullføre prosessen. Du trenger en personlig datamaskin med en seriell port eller en USB-til-seriell adapter og seriell-til-RJ45-kabelen som følger med svitsjen.
Årsak
Svitsjen sitter fast i en inkonsekvent tilstand på grunn av inkompatibel CPLD-versjon.
En svitsj går inn i en inkonsekvent tilstand når CPLD-en som er installert, er en nyere versjon enn fastvaren som skal nedgraderes. Når du nedgraderer fastvaren, må du vurdere CPLD-versjonen og nedgradere den om nødvendig.
Fastvareversjon 6.0.1.3 krever for eksempel CPLD versjon 13.
Hvis en kunde nedgraderer svitsjen fra en nyere fastvareversjon 6.6.0.2 med CPLD 20 direkte til 6.0.1.3, uten å følge fremgangsmåten for riktig nedgradering, kan svitsjen bli sittende fast i en inkonsekvent tilstand.
Du finner CPLD-versjonen som er kompatibel for fastvareversjonen i produktmerknadene som følger med den tilsvarende fastvarenedlastingsfilen.
Slik vet du om en svitsj sitter fast i en inkonsekvent tilstand
Når du starter svitsjen, vises det en loggmelding som angir «systemet starter på nytt på grunn av inkonsekvent tilstand».
Eksempel på konsolllogger
Nedenfor finner du et eksempel på konsolllogg for svitsj under oppstart som viser at svitsjen er i en inkonsekvent tilstand (utelater fullstendig oppstartssekvens for kortfattethet).
Utpakking av driftskode fra .stk-fil ... 2
ferdig.
Laster driftskode ... Gjort.
Dekomprimering av driftskode ... Gjort.
Dekomprimering av apps.lzma
SyncDB kjører ...
Fil: stm_api.c, linje: 62, feil 0 (0x0)
<185> 14. mai 01:38:40 0.0.0.0-0 Generelt [fp_main_task]: stm_api.c(62) 1 %% Feil 0 (0x0)
DMA-utvalgsstørrelse:
16777216 AXI-enhet 0: Dev 0xb342, Rev 0x01, brikke BCM56342_A0, driver BCM56340_A0
I hpcLocalUnitTypeIdGet:611, finner ikke kortet
i sysapiHpcStmUnitDbEntryLocalUnitIndexGet:342, finner ikke kortet
Systemet starter på nytt på grunn av inkonsekvent tilstand 0 i filen: stm_api.c linje 62
<184> 14. mai 01:38:43 0.0.0.0-1 LOG [fp_main_task]: log_cnfgr.c(1357) 3 %% Systemet starter på nytt på grunn av inkonsekvent tilstand.
Finner ikke enhetsnummer!
Bytte programvare SIGSEGV Handler
Denne builden ble konfigurert til å kopiere denne krasjinformasjonen til en fil.
Symboler er allerede lastet inn.
starter pid 12
synkroniseringsfilsystemer.... Dette kan ta litt tid
å starte systemet på nytt!
Systemet går ned NÅ!
Sendte SIGTERM til alle prosesser
som sendte SIGKILL til alle prosesser
der systemet ble startet på nytt
Løsning
Start svitsjen i riktig fastvareversjon (kompatibel med CPLD-versjonen), og fortsett med riktig nedgraderingsprosedyre.
Alternativ 1Start svitsjen i sikkerhetskopieringspartisjonen. Det er en sjanse for at kunden nettopp har kopiert den eldre fastvaren til sikkerhetskopieringspartisjonen og prøver å starte svitsjen på nytt i sikkerhetskopieringspartisjonen.
Oppstartsalternativer for
Dell Networking============================
Valg et menyalternativ innen 3 sekunder, ellers vil driftskoden starte automatisk ...
1 – Start Driftskode
2 – Vis oppstartsmeny
når oppstartsmenyen vises, velger du 2 Display Boot Menu (Skjermoppstartsmeny).
Velg (1, 2) #2
Boot Main Menu
==============
1 - Start Operational Code
2 - Select Baud Rate
3 - Retrieve Logs
4 - Load New Operational Code
5 - Display Operational Code Details
9 - Reboot
10 - Restore Configuration to Factory Defaults
11 - Activate Backup Image
12 - Start Password Recovery
From Boot Main Menu select 11 "Activate Backup Image"
(Aktiver sikkerhetskopiimage).Skriv inn valg nr. 11
etter dette, og start svitsjen på nytt med alternativ 9 for omstart.
Hovedmenyen
for oppstart==============
1 – Start driftskode
2 – velg Overføringshastighet
3 – Hent logg 4 – Last inn ny driftskode
5 – Vis driftskodeinformasjon
9 – Start på nytt
10 – Gjenopprett konfigurasjonen til fabrikkinnstillingene 11 – Aktiver
sikkerhetskopiimage
12 – Start passordgjenoppretting
, angi valg nr. 9
alternativ 2
Hvis alternativet 1stikke fungerte, kan du prøve å laste fastvare ved hjelp av TFTP/XMODEM. Følg fremgangsmåten i oppgraderingsveiledningen for svitsjoppretting.
- Hvis den forrige fastvareversjonen er kjent, må du oppgradere til denne versjonen.
- Hvis fastvareversjonen er ukjent, oppgraderer du den til den nyeste tilgjengelige fastvareversjonen
Når svitsjen er gjenopprettet, følger du den riktige fremgangsmåten for nedgradering som følger med oppgraderingsveiledningen som følger med nedlastingsfilen for fastvaren. Oppgrader til en mellomliggende fastvareversjon N3000_N2000vB.6.3.2.stk og nedgrader CPLD til 13.
Cause
En svitsj går inn i en inkonsekvent tilstand når CPLD-en som er installert, er en nyere versjon enn fastvaren som skal nedgraderes. Når du nedgraderer fastvaren, må du vurdere CPLD-versjonen og nedgradere den om nødvendig.
Resolution
Start svitsjen i sikkerhetskopieringspartisjonen. Det er en sjanse for at kunden nettopp har kopiert den eldre fastvaren til sikkerhetskopieringspartisjonen og prøver å starte svitsjen på nytt i sikkerhetskopieringspartisjonen.
Alternativ 2
Hvis alternativet 1st ikke fungerte, kan du prøve å laste inn fastvare ved hjelp av TFTP/XMODEM. Følg fremgangsmåten i oppgraderingsveiledningen for svitsjoppretting.