Återställa DELL EMC Networking N2000 och N3000 från inkonsekvent tillstånd vid nedgradering av fast programvara

Summary: Återställa DELL EMC Networking N2000 och N3000 från inkonsekvent tillstånd vid nedgradering av fast programvara

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


I den här artikeln beskrivs hur du återställer switchen från inkonsekvent läge vid nedgradering av version av fast programvara i Dell N2000 och N3000.
 

krav


Konsolåtkomst till switchen är ett måste.  Du måste ha fysisk åtkomst till switchkonsolporten för att kunna slutföra processen.  Du behöver en persondator med en seriell port eller en USB-till-seriell adapter och den seriell-till-RJ45-kabel som medföljer switchen.

Orsak


Switchen har fastnat i ett inkonsekvent läge på grund av inkompatibel CPLD-version.
En switch hamnar i ett inkonsekvent tillstånd, när CPLD som är installerat är en nyare version än den fasta programvaran, som ska nedgraderas.  Varje gång du nedgraderar den fasta programvaran måste du överväga CPLD-versionen och nedgradera den om det behövs.
Till exempel, version 6.0.1.3 av den fasta programvaran kräver CPLD version 13.
Om en kund nedgraderar switchen från en senare version av den fasta programvaran 6.6.0.2 med CPLD 20 direkt till 6.0.1.3 kan switchen fastna i ett inkonsekvent läge utan att följa rätt nedgraderingsprocedur.
Du hittar CPLD-versionen som är kompatibel för den fasta programvaruversionen i den versionskommentarer som medföljer motsvarande fil för nedladdning av fast programvara.


 

Ta reda på om en switch har fastnat i ett inkonsekvent läge


När du startar switchen visas ett loggmeddelande om att systemet startas om på grund av inkonsekvent status.

Exempelkonsolloggar

Nedan visas ett exempel på konsollogg för switchen vid start som visar att switchen är i ett inkonsekvent läge (omitting complete boot sequence for brevity).

Extraherar driftkoden från .stk-filen... 2
klart.
Läser in driftkod ... Gjort.
Expanderar driftskoden ... Gjort.
Packa upp apps.lzma
SyncDB running ...
Fil: stm_api.c, rad: 62, fel 0 (0x0)
<185> maj 14 01:38:40 0.0.0.0-0 General[fp_main_task]: stm_api.c(62) 1 %Error 0 (0x0)
DMA pool size:
16777216 AXI-enhet 0: Dev 0xb342, Rev 0x01, Chip BCM56342_A0, drivrutin BCM56340_A0
I hpcLocalUnitTypeIdGet:611 kunde inte kortet Hitta kortet
I sysapiHpcStmUnitDbEntryLocalUnitIndexGet:342 gick det inte att hitta kortet

Systemet startar om på grund av den inkonsekventa status 0 i filen: stm_api.c line 62
 <184> 14 maj 01:38:43 0.0.0.0-1 LOG[fp_main_task]: log_cnfgr.c(1357) 3 %Systemet startas om på grund av inkonsekvent läge.     
                           
Det går inte att hämta enhetsnumret! 
Växling av programvaran SIGSEGV Handler
Den här versionen har konfigurerats för att kopiera kraschinformationen till en fil.
Symboler som redan har lästs in.
startar pid 12
och synkroniserar filsystem. ... Det kan ta några ögonblick
när systemet startas om!
Systemet stängs AV NU!
Skickade SIGTERM till alla processer
skickade SIGKILL till alla processer
som begärde omstart av systemet


 

Lösning

Starta switchen i rätt version av den fasta programvaran (kompatibel med CPLD-versionen) och fortsätt med rätt nedgraderingsprocedur.

Alternativ 1

Starta switchen i säkerhetskopieringspartitionen. Det finns en risk att kunden just har kopierat den äldre fasta programvaran till säkerhetskopieringspartitionen och försöker starta om switchen i säkerhetskopieringspartitionen.

Dell Networking Boot Options
============================
Välj ett menyalternativ inom 3 sekunder annars startar driftskoden automatiskt ...
1 – Starta driftkod
2 – Visa startmenyn


När startmenyn visas väljer du 2 "Display Boot Menu".

Välj (1, 2) huvudmenyn
för start nr 2
==============
1 – Starta driftskod
2 – välj Baud Rate
3 – Retrieve Logs
4 - Load New Operational Code
5 - Display Operational Code Details
9 - Reboot
10 - Restore Configuration to Factory Defaults
11 - Activate Backup Image
12 - Start Password Recovery

From Boot Main Menu select 11 "Activate Backup Image".

Ange val nr 11

. Efter detta startar du om switchen med alternativ 9 "Reboot" (starta om).

Huvudmenyn
för start==============
1 – Starta driftskod
2 – Välj Baud Rate
3 - Retrieve Logs
4 - Load New Operational Code
5 - Display Operational Code Details
9 - Reboot
10 - Restore Configuration to Factory Defaults
11 - Activate Backup Image
12 - Start Password Recovery

Enter Choice# 9

Option 2
Om alternativet 1st
inte fungerade försöker du att läsa in fast programvara med TFTP/XMODEM. Följ anvisningarna i uppgraderingsguiden för switchåterställning.

  • Om du känner till den tidigare versionen av den fasta programvaran uppgraderar du till den versionen.
  • Om versionen av den fasta programvaran är okänd uppgraderar du den till den senaste versionen av den fasta programvaran som är tillgänglig



När switchen återställs följer du den korrekta nedgraderingsproceduren som finns i uppgraderingsmanualen som ges med hämtningsfilen för den fasta programvaran. Uppgradera till mellanliggande version av fast programvara N3000_N2000vB.6.3.2.stk och nedgradera CPLD till 13.



 

Cause

Switchen har fastnat i ett inkonsekvent läge på grund av inkompatibel CPLD-version.
En switch hamnar i ett inkonsekvent tillstånd, när CPLD som är installerat är en nyare version än den fasta programvaran, som ska nedgraderas.  Varje gång du nedgraderar den fasta programvaran måste du överväga CPLD-versionen och nedgradera den om det behövs.

Resolution

Alternativ 1

Starta switchen i säkerhetskopieringspartitionen. Det finns en risk att kunden just har kopierat den äldre fasta programvaran till säkerhetskopieringspartitionen och försöker starta om switchen i säkerhetskopieringspartitionen.

Alternativ 2
Om alternativet 1:a inte fungerar kan du försöka att läsa in den fasta programvaran med TFTP/XMODEM. Följ anvisningarna i uppgraderingsguiden för switchåterställning.

Affected Products

PowerSwitch N2000 Series, PowerSwitch N3000 Series, SmartFabric OS10 Software
Article Properties
Article Number: 000143229
Article Type: Solution
Last Modified: 11 Oct 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.