AppSync: Oracle Database Recovery fails when attempting to change owner of archive log destination

Summary: Chown command of archive log directory fails because the directory itself does not exist on the mount host.

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Symptoms



When trying to mount and recover an Oracle Database copy, the service plan fails during the "pre-Recover Database" step with the following errors:

The Service Plan events will show:
Recover copy, MILE_000005,<AppSync Server>,Recover copy phase for <DBNAME> completed with errors
Recover copy, GENL_000055,<AppSync Server>,An error occurred while running preRecoverDatabase on host <MOUNTHOST>. Refer xxx.log on the agent host for more details.

The AppSync Server log will show:
ERROR [EJB default - 6] [com.emc.archway.service.sshservice.SshServiceBean] [<AppSync Server>] [] ->>> ACP failed, dumping stderr: Traceback (most recent call last):
  File "/usr/local/lib/python3.3/site-packages/cx_Freeze/initscripts/Console3.py", line 27, in <module>
  File "acp.py", line 146, in <module>
  File "acp.py", line 118, in main
  File "generic/oracle.py", line 117, in run
  File "generic/oracle.py", line 618, in preRecoverDatabase
  File "generic/oracle.py", line 2928, in preRecoverDatabase
  File "generic/oracle.py", line 4458, in changeOwner
  File "/jenkins/lglbi061/workspace/Build-Linux-3.8.0.0/urm/appsync/3.8.0.0/integration/acp/src/appsync/acputil.py", line 656, in execute
acputil.ShellException: Command 'chown -R 1000:1000 /archives/
<Filesystem name>/' failed with error code 1: ['chown: cannot access \u20xx/archives/<Filesystem name>/\u20yy: No such file or directory']

The AppSync plugin log on the Mount host, referred to in the Service Plan event to view for more details will show the command being executed, but nothing will follow, like so:
acputil.py[643]:execute() Info:Running command: chown -R 1000:1000 /archives/<DBNAME>/

Cause

The archive log directory was created as /archive/<Filesystem name> when creating the oracle database, but the filesystem name on which it was mounted was /archive. In the AppSync database, the archive destination is saved as /archive/<Filesystem name>, the same name which is provided when creating the database.

When AppSync mounts the copy and tries to recover, it takes the destination from the AppSync database and tries to change the ownership on the destination. Since AppSync mounted it as /archive,  /archive/<Filesystem name> does not exist on the mount host. The reason being that a path isn't specified in "path mapping settings" for /archive which will default mount it to /archive on mount host.

The directory /archive/<Filesystem name> doesn t exist on the mount host, but while changing the permission AppSync finds the name from the database.

Resolution

AppSync Engineering has released a hotfix for this issue. Please open a ticket with Dell EMC Technical Support and quote this article ID to obtain the hotfix. 

This hotfix will be incorporated into a future releases of AppSync. Check future release notes to confirm if this issue is resolved in the version you wish to install.

Additional Information

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Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000168360
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  4
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