NetWorker: File-system recovery is failing with error "file Index is missing"

Summary: File system recovery is failing with error "file Index is missing Please contact the system administrator to recover or re-create the index."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

An error is returned stating that the file index is missing when performing file level recovery of a NetWorker client from the NetWorker Management Console (NMC):

Error Message: File Index is Missing
Figure 1: Error Message: File Index is Missing.

Cause

The client file index folder is missing or empty:

Linux: /nsr/index/CLIENT-NAME
Windows: C:\Program Files\EMC NetWorker\nsr\index\CLIENT-NAME

Screenshot of Missing Client File Index Folder
Figure 2: Screenshot of Missing Client File Index Folder
 

Resolution

On the NetWorker server, open an admin prompt and run as root:

nsrck -L7 client-name
NOTE: Client-name should match how the client name is specified in Clients tab of NetWorker Management Console; optionally the nsraldb on the NetWorker client also shows this. On the NetWorker client, open an admin prompt and run as root: 
nsradmin -p nsrexecd "nsrla"


Monitor the nsrck command output for any errors. Once completed, the client index folder should be repopulated and the data restore can be performed.

Additional Information

This is not applicable to file level recoveries of VMware Virtual Machines backed up using the NetWorker VMware Protection (NVP) vProxy appliance.

Affected Products

NetWorker Family
Article Properties
Article Number: 000200061
Article Type: Solution
Last Modified: 19 Mar 2025
Version:  4
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