NetWorker-Virtualisierung: DAS VM-Backup schlägt mit dem Fehler "Backup has FAILED. Unable to open previous backup."
Summary: VM-Backup schlägt fehl mit Fehler: Backup ist fehlgeschlagen: Backup ist FEHLGESCHLAGEN. Vorheriges Backup kann nicht geöffnet werden. Der Backupdeskriptor der Version 1 konnte nicht aus der Datei "/path/Backup targets/BackupDescriptor.json" geladen werden: JSON-Codierung aus Eingabestream konnte nicht gelesen werden: [5040] Ruft system() an, gibt nonzero zurück ...
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Symptoms
Fehlermeldung:
Backup has failed: Backup has FAILED. Unable to open previous backup. Failed to load version 1 backup descriptor from file '/path to backup targets/42/61/cf4ce8c5-00000006-1564ebb4-6464ebb4-77ec5000-4975b756/BackupDescriptor.json': Failed to read JSON encoding from input stream: [5040] calling system(), returns nonzero
Standort: Navigieren Sie zur Registerkarte NMC > Monitoring > Wählen Sie die dedizierte Richtlinie und den Workflow aus, in der diese bestimmte VM fehlschlägt > Doppelklicken Sie auf Öffnen > Klicken Sie aufMeldungsprotokolle anzeigen > Kopieren Sie die gesamten Protokolle und fügen Sie sie in eine Notepad-Datei ein.
Cause
- Da der Vproxy nicht mehr reagiert, muss er deaktiviert oder ordnungsgemäß neu gestartet werden.
- Da der ESXI-Host nicht in der Lage ist, das Backup zu erfassen, da es viel Last darauf gibt, führt dies dazu, dass der ESXI in den Status "Not responding" oder "Stale ESXI" wechselt (d. h. nicht ordnungsgemäß funktioniert).
- Wenn der Backupworkflow den "PreviousBackupPath" und die "CurrentBackupPath"-Geräte auf verschiedenen MTrees verwendet, schlägt das Backup fehl. Wenn der Backupworkflow die Geräte "PreviousBackupPath" und "CurrentBackupPath" auf demselben MTree verwendet, wurden die Backups erfolgreich abgeschlossen. Der Zielbackuppool muss Geräte aus derselben Data Domain enthalten, es wird jedoch unterstützt, die Geräte in unterschiedlichen MTrees zu haben.
Resolution
Aktionsplan:
Option A:
- Stellen Sie sicher, dass die Data Domain-Geräte ordnungsgemäß in der Umgebung konfiguriert sind. Falls erforderlich, erstellen Sie einen neuen Zielbackuppool mit Geräten unter demselben Data Domain-MTree.
- Das Neustarten der vProxies und in einigen Fällen muss es auch neu gestartet werden, um das Problem zu beheben.
Option B:
>>Melden Sie sich bei NMC an, wenn das Backup mit der oben genannten Fehlermeldung fehlgeschlagen ist.->Must gehen Sie zur Registerkarte "Protection " und dann zu "Policies".
->: Aktivieren Sie den dedizierten Workflow.
-> Ändern Sie die Konfiguration auf "Full " und konfigurieren Sie sie dann.
->Post, indem Sie die oben genannten Schritte ausführen, lösen Sie die VM durch Starten des einzelnen Clients aus.
->Post, der als "Full" ausgelöst wird, kehren Sie zur Konfiguration zurück, um zu erfahren, wie es früher war.
Höchstwahrscheinlich ist die Sicherung nach dem oben genannten Aktionsplanerfolgreich.
Additional Information
Nachfolgend finden Sie zwei Fälle, in denen die Lösung funktioniert hat.
Fällen: SR#128403734, SR#107428962
Article Properties
Article Number: 000214585
Article Type: Solution
Last Modified: 30 Aug 2023
Version: 5
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