PowerProtect: SQL App Agent backups fail with ABA0002 "Lockbox contains no entries"

Summary: Microsoft SQL Server database backups fail with error ABA0002, indicating an error when accessing the lockbox.

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Symptoms

The PowerProtect Data Manager for Microsoft Application Agent is used to protect Microsoft SQL Server databases. Microsoft SQL Server database backups fail with ABA0002, indicating an error when accessing the lockbox.
ABA0002: MY_MSSQL_POLICY: Unable to backup MICROSOFT_SQL_DATABASE asset MY_DATABASE on my-server.my-domain.com to storage target MY_MSSQL_POLICY_STORAGE because of an agent issue.

The protection policy backup was unsuccessful because of an agent issue.

Review the error message for a resolution. If there is no resolution, and the issue persists, contact Dell Customer Support.

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The protection policy configuration was unsuccessful because the Agent failed with the following error: Error encountered while retrieving information from the lockbox 'C:\Program Files\DPSAPPS\common\lockbox\agents.clb' The Lockbox contains no entries.

Cause

The agent.clb lockbox information is corrupt. The root cause of the corruption is not known.

Resolution

Rename the agent.clb lockbox file to re-create the content.

  1. Authenticate to the Microsoft Application Agent Client experiencing the symptom.
  2. In Windows Explorer, browse to the lockbox directory (C:\Program Files\DPSAPPS\common\lockbox).
  3. Rename the existing agents.clb file to agents.clb.old.
  4. Restart the Dell VM Direct Agent service using the Services console (services.msc).
  5. Start a Microsoft Application Agent SQL Agent backup to re-create the agents.clb lockbox content.
Article Properties
Article Number: 000224362
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  2
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