PowerProtect Cyber Recovery: Falha na instalação com erro: "Falha ao conectar ao banco de dados Mongo."

Summary: Este artigo descreve como resolver o erro em que o Cyber Recovery não consegue se conectar ao MongoDB durante o upgrade após a instalação da atualização do SO do Cyber Recovery.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A verificação de upgrade do Cyber Recovery falha porque o upgrade "Failed to connect to database: Falha ao conectar ao banco de dados Mongo."
cr:/tmp/Upgrade/staging # ./crsetup.sh --upgcheck
24.04.30 07_17_26 : =================================================================================================
24.04.30 07_17_26 : Cyber Recovery Pre-upgrade check.
24.04.30 07_17_26 : =================================================================================================
24.04.30 07_17_26 : Using timezone 'Europe/Dublin' for Cyber Recovery service containers...
24.04.30 07_17_26 :
24.04.30 07_17_26 : Determining the docker bridge network IP...
24.04.30 07_17_26 :
24.04.30 07_17_26 : Using IP Address 172.17.0.1 to send mail from the notifications container...
24.04.30 07_17_26 : Docker Client & Server versions .......... PASSED (Installed Docker Server (Engine) version 24.0.7 meets the minimum Docker 23.0+ requirement)
24.04.30 07_17_26 : Docker Compose version ................... PASSED (Installed Docker Compose version 2.23.3 meets the minimum Docker 2.3+ requirement)
lockbox's passphrase:

Verify CR install version................. PASSED (Installed CR version 19.14.0.2-16 is upgradeable to 19.16.0.2-10)
Verify OS support ........................ PASSED (Installed SuSE OS version 12.5 meets the minimum 12.5 requirement)
Verify CR registry service ............... PASSED (Cyber Recovery registry service is running)
Verify CR OS size requirement ............ PASSED (Cyber Recovery upgrade disk size 26 GB meets or exceeds the minimum 2 GB requirement.)


Failed to connect to database : Failed to connect to Mongo Database.


24.04.30 07_17_59 :
24.04.30 07_17_59 : Pre-upgrade software check failed.
24.04.30 07_17_59 :
O contêiner do Docker não está ativo e o comando docker ps --all exibe o status do MongoDB como "Exited".
cr:/tmp/Upgrade/staging # docker ps --all
...
6539b68a2ec7   localhost:14779/cr_mongo:6.0.6                    "/bin/bash /usr/loca…"   7 months ago   Exited (0) 23 hours ago                                                           cr_mongo-auth_1
Outros contêineres também estão no status "Exited".

Cause

Durante a instalação da atualização do sistema operacional, a versão do docker foi atualizada, e os contêineres do docker exigem recriação forçada.

Resolution

Execute o seguinte comando:
crsetup.sh --forcerecreate
Tente novamente a verificação de upgrade do Cyber Recovery.

Affected Products

PowerProtect Cyber Recovery
Article Properties
Article Number: 000224618
Article Type: Solution
Last Modified: 01 May 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.