PowerProtect: Kubernetes protection job fails to take a snapshot of the in-use volume.

Summary: Protection job fails to take a snapshot of in-use volume.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager Kubernetes protection jobs fail with an error message similar to the following:

Unable to create snapshots. Unable to snapshot PVC 'Test-pvc' in namespace 'backup-test'. 
Unable to create snapshot 'backup-test-xxxx-xx-xx-xx-xx-xx-test-pvc': Snapshot Creation Error : 'Failed to check and update snapshot content: failed to take snapshot of the volume <volumeID>: "rpc error: code = Internal desc = CreateSnapshot failed with error Bad request with: [POST http://<IPAddress>:8776/v3/xxxxxxxxxxxxxxxxxxxxxxx/snapshots [IPAddress]], error message: {\"badRequest\": {\"code\": 400, \"message\": \"Invalid volume: Volume <VolumeID> status must be available, but current status is: in-use.\"}}"'

CSI Driver: OpenStack Cinder CSI

Cause

The 'force-create' parameter for the VolumeSnapshotClass resource is set to 'False'. 

Resolution

To take a snapshot of in-use volumes, set the 'force-create' parameter for VolumeSnapshotClass to 'True'.
More details about the parameter can be found at the following documentation links for OpenStack and Cinder CSI plugin (last checked on 21st August 2025):
GitHub - kubernetes/cloud-provider-openstack
OpenStack - volume snapshot

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software, PowerProtect DM5500
Article Properties
Article Number: 000225034
Article Type: Solution
Last Modified: 21 Aug 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.