Dell Display Manager Does Not Work on External Thunderbolt Monitors Connected to Dell Laptops Using the Qualcomm CPU

Summary: The following article provides information about a Dell Display Manager (DDM) problem that occurs on Dell Laptops running a Qualcomm Central Processor Unit (CPU). Connecting the laptop directly to external Thunderbolt monitors stops the DDM utility from working correctly. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DDM stops working when a Thunderbolt monitor connects directly to a Dell Qualcomm Laptop

 

Owners of a Dell Qualcomm laptop may experience a problem with DDM on their external Thunderbolt monitors. (For example: The Latitude 7455 laptop.) DDM stops working correctly when connected directly to the laptop using a Thunderbolt Type-C to Type-C cable.

You may experience one of the following DDM failures:

  • Symptom One: DDM has not aligned the brightness or contrast with the Monitors On-Screen Display (OSD) value.

  • Symptom Two: DDM PowerNap is enabled but the monitor brightness does not dim, or the external monitor does not go into sleep mode.

  • Symptom Three: Only Easy Arrange items work, all other features are unavailable.

  • Symptom Four: The Ambient Light Sensor (ALS) is enabled in DDM, but this does not synch to a second external monitor.

Cause

The Command Interface (CI) on the Display Data Channel (DDC) does not work on Thunderbolt monitors. This causes the DDM to behave abnormally.

Resolution

Note: People that use a Type-C display dongle or connect through a Dell docking station do not see the same problems with DDM.
 

Update the video driver to Qualcomm Adreno X1-85 Graphics Driver, version 31.0.60.1, A02 or later. To download and install the Qualcomm-Adreno-X1-85-Graphics-Driver_F9N8F_WINARM64_31.0.60.1_A02.exe see:

Affected Products

Inspiron 14 Plus 7441, Latitude 7455, XPS 13 9345
Article Properties
Article Number: 000226546
Article Type: Solution
Last Modified: 24 Jul 2024
Version:  1
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