NetWorker: Can not run save: Unknown action 2 requested. Rejecting request.

Summary: A NetWorker backup fails with error: can not run save: Unknown action 2 requested. Rejecting request.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After an upgrade of the client's version the backup started to fail with error: 
save: Can not run save: Unknown action 2 requested.  Rejecting request. 

 

Cause

Issue start after upgrading the client to 19.11 which is higher than the NetWorker server version 19.10.0.6

This same error could arise for other backups, not only filesystem backups.

For instance, if doing a NMC backup, where NMC is on 19.11 version, and NetWorker server on 19.10.0.6, the error would be:

savepsm: Can not run savepsm: Unknown action 2 requested.  Rejecting request.

 

Resolution

NetWorker client version has to be the same or lower than NetWorker server
NetWorker_Interop_Report.pdf 

In the case of NMC, 19.11 Compatibility guide shows NMC as compatible with NetWorker server 19.10.

This compatibility refers to the UI management. You can use a NMC server in 19.11 to manage a NetWorker server in 19.10, however, the client compatibility will still apply, and NMC backups might fail.

Article Properties
Article Number: 000281812
Article Type: Solution
Last Modified: 17 Mar 2025
Version:  2
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