Avamar 19.7/19.8 No se puede recuperar el contenido de respaldo cuando la autenticación de certificados de DD falla o se deshabilita

Resumen: Avamar 19.7/19.8 7: No se puede recuperar el contenido de respaldo cuando la autenticación de certificado de DD falla o se deshabilita.

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

En Avamar 19.7/19.8, es posible que los respaldos en Data Domain no se enumeren ni se restauren, y vemos los siguientes errores en AUI.

Lista de respaldos de Avamar 
Los detalles de la vista muestran esta información adicional: 

Detalle del evento



Pestaña Restaurar contenido
 
 

Causa

En Avamar 19.7/19.8, MCS intenta iniciar sesión en DD con autenticación de certificados de manera predeterminada cuando se exploran respaldos en Data Domain. En algunos ambientes, este inicio de sesión de DD puede fallar.  

Para confirmar que este inicio de sesión de DD falla, compruebe la siguiente ubicación de registro:
/usr/local/avamar/var/mc/server_log/mcserver.log.0 

En mcserver.log.0, vemos el siguiente error que indica que, en este entorno, el inicio de sesión de DDR está fallando. 
FINE: exec avtar 1 : exit code: '170: /usr/local/avamar/bin/avtar --showlog --noinfo --seq=1 --path=vc.example.com/vm1_Esks0jsQM6ei34MQsDyBFw workorder --id=MCUser --ap=******* --hfsaddr=ave --hfsport=27000 --conntimeout=120 --ddr-auth-enabled=true --ddr-auth-mode=2 --vardir=/usr/local/avamar/var ' elapsed time: 1310ms
[RMI TCP Connection(1385)-ave#39854] com.avamar.mc.util.MCException.logException
WARNING: java.io.IOException: avtar Warning : Calling DDR_OPEN returned result code:5049 message:file not found
avtar Error : Data Domain server "ddve.example.com" open failed DDR result code: 5049, desc: file not found
avtar Error : Problem logging into the DDR server index:1

  at com.avamar.mc.dpn.AvtarCmd.execAvtar(AvtarCmd.java:223)
  at com.avamar.mc.dpn.DPNProxyService.getVmBackupConfig(DPNProxyService.java:6033)
  at com.avamar.mc.burm.BackupRestoreManagerService.getVmBackupConfig(BackupRestoreManagerService.java:3064)
  at sun.reflect.GeneratedMethodAccessor246.invoke(Unknown Source)

Resolución

El equipo de ingeniería de Avamar está investigando este problema. 

Para resolver este problema de la lista de respaldos, podemos realizar una de las siguientes soluciones alternativas:

Pasos:
1. Ejecute el siguiente comando en Avamar Server: 
admin@ave197:~/>: grep secure_dd /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
Ejemplo de salida 1 (deshabilitado)
 
Ejemplo de salida 2 (habilitado)
 
  


Solución alternativa 1:  Si la salida muestra "false", vaya al paso 2, si la salida es true, vaya al paso 3. 

2.  Como root, respalde /usr/local/avamar/bin/avtar:

cp -p /usr/local/avamar/bin/avtar /usr/local/avamar/bin/x-avtar.`date -I`


A continuación, edite el archivo /usr/local/avamar/bin/avtar y cambie la parte inferior del archivo a lo siguiente:
ANTES

# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
DESPUÉS  
# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
if [[ "$*" == *--ddr-auth-enabled=true* ]]
then
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@" --ddr-auth-mode=3 --ddr-auth-enable=false
else
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
fi
 Esto debería resolver el problema de la lista y puede detenerse aquí.

Solución alternativa 2
3.  Si secure_dd_feature_on es verdadero, siga estos pasos.  
admin@ave197:~/>: openssl x509 -in /home/admin/chain.pem -noout -fingerprint
SHA1 Fingerprint=81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6
4. Obtenga el nombre de usuario y el nombre de host para uno o más dominios de datos que contienen el respaldo de VM mediante el comando ddrmaint.
admin@ave197:~/>: ddrmaint read-ddr-info --format=full
====================== Read-DDR-Info ======================

 System name        : ddve.example.com
 System ID          : EXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 DDBoost user       : ddboost 
NOTA: Si se agrega más de un Data Domain a Avamar, repita los pasos de ejecución del 5 al 7 en cada DD enumerado.

5. Ejecute el siguiente comando ssh en DD para comprobar si la huella digital SHA1 se cargó en DD. 
admin@ave197:~/>: ssh ddboost@ddve.example.com  -i /usr/local/avamar/lib/ddr_key   "adminaccess certificate show imported-ca"| grep -c 

Ejemplo de un buen resultado: 
admin@ave197:~/>:  ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 
EMC Data Domain Virtual Edition
1
Ejemplo de salida en mal estado: 
 ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 
EMC Data Domain Virtual Edition
0

6. Si el certificado NO está presente, realice el siguiente comando para importar el certificado.
admin@ave197:~/>: cat chain.pem | ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate import ca application ddboost"     
7. A continuación, reinicie ddboost. 
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost disable " 
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost enable"

Esto debería resolver el problema de la lista. Si el problema no se resuelve, implemente la solución alternativa 1 y comuníquese con el soporte de Dell. 

Productos afectados

Avamar, Avamar Server
Propiedades del artículo
Número de artículo: 000203335
Tipo de artículo: Solution
Última modificación: 10 ago 2023
Versión:  12
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.