NetWorker: Kan zich niet aanmelden bij NMC of nsrlogin gebruiken, ontvangt: "Fout in authenticatiebibliotheek: GET mislukt met HTTP-ERROR: 404"

概要: Kan zich niet aanmelden bij de NMC of met behulp van de opdracht nsrlogin van CLI op de NetWorker server. Dit KB-artikel gaat over dit probleem/de oplossing wanneer ook wordt vastgesteld dat de nsr-map op de NetWorker-server 100% capaciteit heeft. ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • U kunt zich niet aanmelden bij de NetWorker Management Console (NMC) of CLI met behulp van nsrlogin  
  • NetWorker-verificaties mislukken met de volgende fout:
image

Fout in authenticatiebibliotheek: GET mislukt met HTTP-ERROR: 404
Serverbericht: Kan serverrespons niet parseren vanuit json string
Server Message: Controleer of de server actief is

  • De NetWorker Server (nsrd)-service wordt uitgevoerd:
    • Linux: ps -ef | grep nsr
    • Windows: tasklist | findstr nsr
  • Poort 9090 luistert:
    • Linux: netstat -apno | grep 9090
    • Windows: netstat -ano | findstr 9090

原因

Dit probleem kan onder verschillende omstandigheden optreden:
  • Na de upgrade/installatie van NetWorker op een Windows-server.
  • Nadat /nsr installatielocatie 100% capaciteit heeft bereikt.
  • authcdb-corruptie.
De authc-service is gestart, maar reageert niet op verificatieaanvragen.

解決方法

Voordat u stappen onderneemt om het probleem op te lossen, moet u controleren of de installatieschijf niet 100% capaciteit heeft. Als het installatiestation vol is of de capaciteit nadert, vergroot u de schijfruimte dienovereenkomstig.

De authcdb moet opnieuw worden geconfigureerd.

Linux:

1. Sluit NetWorker-services af:
nsr_shutdown2. Wijzig de naam van de authc-map: mv /nsr/authc /nsr/authc'date -I'.bak
3. Voer het authc-configuratiescript uit: /opt/nsr/authc-server/scripts/authc_configure.sh
Opmerking: U wordt gevraagd om het wachtwoord van de authc keystore en het NetWorker Administrator-wachtwoord opnieuw te configureren.
4. NetWorker-services starten: systemctl start networker
5. Bevestig dat de NetWorker-services worden geleverd: ps -ef | grep nsr
6. Controleer of poort 9090-verbindingen slagen: nsrports -t localhost -p 9090
Opmerking: De authc-service wordt weergegeven als een jsvc.exe-proces voor nsrtomcat+. Dit kan worden waargenomen bij 'ps -ef | grep jsvc'

7. Meld u aan bij de NMC of NetWorker Web User Interface (NWUI) met behulp van het NetWorker Administrator-account.
8. Zodra de NetWorker-functionaliteit is geretourneerd, kunt u de oude authc-map naar eigen goeddunken verwijderen.

Windows:

1. Verwijder NetWorker.
2. Ga vanuit Windows Verkenner naar de installatiemap van NetWorker en wijzig de naam van de map authc-server. De standaardlocatie is "C:\Program Files\EMC NetWorker\nsr\authc-server"
3. Installeer NetWorker opnieuw.

Opmerking: NetWorker installatiepakketten kunnen worden gedownload van: https://www.dell.com/support/home/product-support/product/networker/drivers. Tijdens de installatie wordt u gevraagd om de NetWorker keystore en het standaard administratorwachtwoord opnieuw te maken.

4. Bevestig dat de NetWorker-services worden geleverd: taaklijst | findstr nsr
5. Controleer of poort 9090-verbindingen slagen: nsrports -t localhost -p 9090

Het authc-proces wordt vermeld als java.exe-proces. Het tabblad Details in Taakbeheer kan worden gebruikt om dit proces te identificeren: 
image.png

6. Meld u aan bij de NMC of NetWorker Web User Interface (NWUI) met behulp van het NetWorker Administrator-account.
7. Zodra de NetWorker-functionaliteit is geretourneerd, kunt u de oude authc-map naar eigen goeddunken verwijderen.

その他の情報

Als Active Directory/LDAP is geïntegreerd met NetWorker, moet de externe autoriteit worden gelezen naar NetWorker; Alle machtigingen die zijn ingesteld in de NMC-rollen en NSR-gebruikersgroepen voordat de stappen in dit KB-artikel worden voltooid, blijven echter behouden:

対象製品

NetWorker, NetWorker Management Console

製品

NetWorker Family, NetWorker, NetWorker Series
文書のプロパティ
文書番号: 000031476
文書の種類: Solution
最終更新: 20 6月 2025
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。