NetWorker: Nie można zalogować się do NMC lub za pomocą nsrlogin, odbieranie: "Błąd biblioteki uwierzytelniania: Niepowodzenie get z HTTP-ERROR: 404"

概要: Nie można zalogować się do NMC lub przy użyciu polecenia nsrlogin z wiersza poleceń na serwerze NetWorker. Ten artykuł KB dotyczy tego problemu/rozwiązania, gdy okaże się również, że katalog nsr na serwerze NetWorker ma pojemność 100%. ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • Nie można zalogować się do konsoli zarządzania NetWorker Management Console (NMC) lub cli przy użyciu nsrlogin  
  • Uwierzytelnianie NetWorker kończy się niepowodzeniem z następującym błędem:
obraz

Błąd biblioteki uwierzytelniania: Niepowodzenie get z HTTP-ERROR: Komunikat serwera 404
: Nie można przeanalizować odpowiedzi serwera z komunikatu serwera json string
: Upewnij się, że serwer jest uruchomiony

  • Usługa serwera NetWorker (nsrd) jest uruchomiona:
    • Linux: ps -ef | grep nsr
    • Windows: tasklist | findstr nsr
  • Port 9090 nasłuchuje:
    • Linux: netstat -apno | grep 9090
    • Windows: netstat -ano | findstr 9090

原因

Ten problem może pojawić się w różnych okolicznościach:
  • Po uaktualnieniu/instalacji oprogramowania NetWorker na serwerze z systemem Windows.
  • Pojemność po instalacji /nsr osiągnęła 100%.
  • uszkodzenie authcdb.
Usługa authc została uruchomiona, ale nie reaguje na żądania uwierzytelniania.

解決方法

Przed wykonaniem jakichkolwiek czynności w celu rozwiązania problemu należy upewnić się, że dysk instalacyjny nie ma 100% pojemności. Jeśli napęd instalacyjny jest pełny lub bliski pojemności, odpowiednio zwiększ ilość miejsca na dysku.

Należy ponownie skonfigurować authcdb.

Linux:

1. Wyłączanie usług NetWorker:
nsr_shutdown2. Zmień nazwę katalogu authc: mv /nsr/authc /nsr/authc'date -I'.bak
3. Uruchom skrypt konfiguracji authc: /opt/nsr/authc-server/scripts/authc_configure.sh
Uwaga: Zostanie wyświetlony monit o ponowną konfigurację hasła magazynu kluczy authc i hasła administratora NetWorker.
4. Uruchamianie usług NetWorker: systemctl uruchom networker
5. Potwierdź wyświetlenie usług NetWorker: ps -ef | grep nsr
6. Potwierdź powodzenie połączeń portu 9090: nsrports -t localhost -p 9090
Uwaga: Usługa authc jest wyświetlana jako proces jsvc.exe dla nsrtomcat+. Można to zaobserwować w przypadku "ps -ef | grep jsvc"

7. Zaloguj się do sieciowego interfejsu użytkownika NMC lub NetWorker (NWUI) przy użyciu konta administratora NetWorker.
8. Po zwróceniu funkcji NetWorker można usunąć stary folder authc według własnego uznania.

Windows:

1. Odinstaluj oprogramowanie NetWorker.
2. W Eksploratorze plików systemu Windows przejdź do katalogu instalacyjnego NetWorker i zmień nazwę folderu serwera authc. Domyślna lokalizacja to "C:\Program Files\EMC NetWorker\nsr\authc-server"
3. Zainstaluj ponownie networker.

Uwaga: Pakiety instalacyjne NetWorker można pobrać z witryny: https://www.dell.com/support/home/product-support/product/networker/drivers. Podczas instalacji zostanie wyświetlony monit o ponowne wywołanie magazynu kluczy NetWorker i domyślnego hasła administratora.

4. Potwierdź wyświetlenie usług NetWorker: lista zadań | findstr nsr
5. Potwierdź powodzenie połączeń portu 9090: nsrports -t localhost -p 9090

Proces authc jest wymieniony jako proces java.exe. Do identyfikacji tego procesu można użyć karty Szczegóły w Menedżerze zadań
image.png

6. Zaloguj się do sieciowego interfejsu użytkownika NMC lub NetWorker (NWUI) przy użyciu konta administratora NetWorker.
7. Po zwróceniu funkcji NetWorker można usunąć stary folder authc według własnego uznania.

その他の情報

Jeśli usługa Active Directory / LDAP jest zintegrowana z rozwiązaniem NetWorker, należy ponownie dodać zewnętrzny urząd do NetWorker; jednakże wszelkie uprawnienia ustawione w rolach NMC i grupach użytkowników NSR przed wykonaniem czynności opisanych w tej wiedzy zostaną zachowane:

対象製品

NetWorker, NetWorker Management Console

製品

NetWorker Family, NetWorker, NetWorker Series
文書のプロパティ
文書番号: 000031476
文書の種類: Solution
最終更新: 20 6月 2025
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。