Data Domain:故障、不存在、未知或已關閉電源的磁碟
요약: 本文說明如何解決磁碟機處於故障、不存在或關機狀態的狀況。
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
警報 |症狀代碼:
- 事件代碼:
STORAGE-00001, STORAGE-00002, PHYM-00001 - 警示訊息:
Enclosure disk has failed and should be replacedDisk has a hardware fault and may need to be replacedDisk is absent and should be replacedUnable to access the disk; disk state is powered offA disk has failed, and the enclosure slot has been disabled
受影響的產品:
- 所有 Data Domain 系統
- 所有 Data Domain 作業系統 (DDOS) 軟體版本
원인
DDOS 持續監控磁碟健全狀況,並在發生嚴重 I/O 錯誤時自動讓磁碟機故障。
當磁碟處於以下情況時,會產生警示:
- 已移除 (缺席)
- 失效或失敗
- 關閉電源 (手動或由 DDOS 自動關閉,以防止後端問題)
해결
- 驗證並確認故障:
- 使用 DDMC、Data Domain System Manager (DDSM) Web UI 或 DD-CLI (SSH) 確認系統上的警示。
DD-CLI # alerts show current- DDSM
>警示
- 識別並確認系統中所有磁碟機的目前狀態。
DD-CLI # disk show state | AND | # disk show hardware- DDSM >硬體 >儲存裝置 >磁碟
-
磁碟狀態指示燈:
- F = 失敗
- R = 重建
- S = 備用
- A = 缺席
- P = 已關閉電源
-
範例: DD-CLI:
# disk show state
sysadmin@DD# disk show state
Enclosure Disk
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
--------- ----------------------------------------------
1 . . .
2 . . . . . . . . . . . . . . s
3 . . . . . . . . . . . . . . s
4 . . . . . F . . . . . . . . R
--------- ----------------------------------------------
這裡請注意磁碟 4.6 (F) ailled - (R) econstructing 至備援磁碟 4.15。
針對 DD3300 磁碟問題,請考慮此文章 Data Domain:DD3300 將磁碟警示對應到正確的硬碟插槽
- 提出服務要求 (SR)
- 儘快更換單個失敗的磁碟。
- 如果 SR 不是透過 dial home 自動產生:
- 請聯絡您的支援提供者並提出 SR。
- 如果出現多個磁碟故障:
- 請立即聯絡 Dell ProSupport (或您簽約的服務供應商) 以取得指引。
- 在等待更換磁碟時監控系統。
提高 SR 後,請繼續監控以確保系統穩定性。
3.1 瞭解備份繼續的原因。
-
- Data Domain 系統使用 RAID 6 (雙同位檢查)。
- 系統可在磁碟故障期間保護數據。
- DDOS 會自動將資料重建至可用的備援。
- 重建期間會繼續執行備份和還原作業。
3.2 驗證重建狀態。
-
- 執行:
disk show state - 確認磁碟顯示 (R) 建構中。
- 執行:
3.3 監控重建進度
-
- 重新執行
disk show state定期。 - 重建時間取決於磁碟大小和系統負載。
- 重新執行
3.4 注意其他磁碟故障。
-
-
⚠️ 嚴重警告
RAID 6 可容忍每個磁碟群組兩次磁碟故障。
重建過程中的第二次故障增加了風險。 -
如果另一個磁碟發生故障:
- 請立即聯絡 Dell ProSupport (或您簽約的服務提供者)。
-
3.5 識別實體磁碟
-
- 磁碟格式: Enclosure.Slot (例如:
2.27) - 在 DDSM:
- 瀏覽至 硬體 > 儲存 > 磁碟
- 選取磁碟→按一下 指標 以啟用 LED
- 在 DD-CLI 中:
- #
disk beacon n.n
- #
- 磁碟格式: Enclosure.Slot (例如:
3.6 請勿移除故障的磁碟。
-
- 保留安裝故障的磁碟,直到替換磁碟到達。
- 早期移除沒有任何好處,並且可能會使追蹤複雜化。
- 更換失敗的磁碟:
-
請遵循 Data Domain 說明文件中的官方磁碟更換程序
-
最佳實務:
-
從卸下到插入之間等待 2 分鐘 :
- 移除故障磁碟
- 等待 2 分鐘
- 插入替換磁碟
-
這可讓控制器正確取消註冊舊磁碟,並避免熱插拔辨識問題。
-
-
- 確認更換後狀態:
自 DD-CLI # disk show state
-
- DDSM >硬體 >儲存裝置 >磁碟
範例: DD-CLI:
-
-
sysadmin@DD# disk show state Enclosure Disk 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 --------- ---------------------------------------------- 1 . . . 2 . . . . . . . . . . . . . . s 3 . . . . . . . . . . . . . . s 4 . . . . . s . . . . . . . . . --------- ----------------------------------------------
-
-
更換的磁碟會變 為備用磁碟,重建的磁碟將返回使用中。
- 針對更換問題進行故障診斷。
如果新磁碟顯示 為「未知」:
-
- 執行命令
# disk rescan - 確認磁碟狀態的來源
DD-CLI # disk show state
- 執行命令
如果新磁碟回報 故障
-
- 執行命令
# disk rescan - 確認磁碟機狀態的來源
DD-CLI # disk show state - 如果仍有 (F) 錯誤,請從
DD-CLI: # disk unfail <encl.disc>
- 執行命令
例如: # disk unfail 5.6
如果磁碟狀態確認為「OK」(使用中或「備用」),請清除任何相關的警示:
-
- 自
DD-CLI # alerts clear alert-id <alert-id>
- 自
추가 정보
參考資料:
多個磁碟故障?
如果您在短時間內 (數天至
數週) 內發生三次以上磁碟故障,這可能表示發生系統性問題 (例如多重路徑或韌體錯誤),而非個別磁碟故障。
這可能需要額外調查、產生支援套裝,然後聯絡支援部門
해당 제품
Data Domain문서 속성
문서 번호: 000043773
문서 유형: Solution
마지막 수정 시간: 07 7월 2026
버전: 18
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.