Data Domain:故障、不存在、未知或已关机
요약: 本文介绍如何解决磁盘驱动器处于故障、缺失或关机状态的情况。
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
警报 |症状代码:
- 事件代码:
STORAGE-00001, STORAGE-00002, PHYM-00001 - 警报消息:
Enclosure disk has failed and should be replacedDisk has a hardware fault and may need to be replacedDisk is absent and should be replacedUnable to access the disk; disk state is powered offA disk has failed, and the enclosure slot has been disabled
受影响的产品:
- 所有 Data Domain 系统
- 所有 Data Domain 操作系统 (DDOS) 软件版本
원인
DDOS 持续监视磁盘运行状况,并在发生严重 I/O 错误时自动将驱动器故障。
当磁盘处于以下状态时,会生成警报:
- 已删除(不存在)
- 无效或失败
- 关闭电源(由 DDOS 手动或自动,以防止后端问题)
해결
- 验证并确认故障:
- 使用 DDMC、Data Domain System Manager (DDSM) Web UI 或 DD-CLI (SSH) 验证系统上的警报。
DD-CLI # alerts show current- DDSM
>警报
- 识别并确认系统中所有驱动器的当前状态。
DD-CLI # disk show state | AND | # disk show hardware- DDSM >硬件 >存储 >磁盘
-
磁盘状态指示器:
- F = 失败
- R = Reconstructing
- S = 备用
- A = 不存在
- P = 关机
-
示例: DD-CLI:
# disk show state
sysadmin@DD# disk show state
Enclosure Disk
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
--------- ----------------------------------------------
1 . . .
2 . . . . . . . . . . . . . . s
3 . . . . . . . . . . . . . . s
4 . . . . . F . . . . . . . . R
--------- ----------------------------------------------
请注意,磁盘 4.6 (F)ailed - (R)正在构造到备用磁盘 4.15。
对于 DD3300 磁盘问题,请考虑本文 Data Domain:DD3300 将磁盘警报映射到正确的硬盘插槽
- 提交服务请求 (SR)
- 尽快更换单个故障磁盘。
- 如果未通过 Dial Home 自动生成 SR:
- 请联系您的支持提供商并提交 SR。
- 如果存在多个磁盘故障:
- 立即联系 Dell ProSupport (或您的签约服务提供商)以获得指导。
- 在等待更换磁盘的过程中监控系统。
提出 SR 后,继续监视以确保系统稳定性。
3.1 了解备份为何继续进行。
-
- Data Domain 系统使用 RAID 6(双奇偶校验)。
- 系统在磁盘故障期间保护数据。
- DDOS 自动将数据重构到可用的备盘上。
- 在重建期间,备份和恢复操作将继续进行。
3.2 验证重建状态。
-
- 运行:
disk show state - 确认磁盘显示 (R)econstructing。
- 运行:
3.3 监视重建进度
-
- 重新运行
disk show state定期。 - 重建时间取决于磁盘大小和系统负载。
- 重新运行
3.4 观察其他磁盘故障。
-
-
⚠️ 严重警告
RAID 6 可承受每个磁盘组两个磁盘故障。
重建过程中的第二次故障会增加风险。 -
如果另一个磁盘发生故障:
- 立即联系 Dell ProSupport(或您的签约服务提供商)。
-
3.5 识别物理磁盘
-
- 磁盘格式: Enclosure.Slot (例如:
2.27) - 在 DDSM 中:
- 导航至HardwareStorageDisks > >
- 选择磁盘→然后单击 信标 以启用 LED
- 在 DD-CLI 中:
- #
disk beacon n.n
- #
- 磁盘格式: Enclosure.Slot (例如:
3.6 请勿移除故障磁盘。
-
- 在更换的磁盘送达之前,请保持故障磁盘的安装状态。
- 提前删除没有任何好处,并且可能会使跟踪复杂化。
- 更换故障磁盘:
-
按照 Data Domain 文档中的官方磁盘更换过程进行操作
-
最佳做法:
-
在拆卸和插入之间等待 2 分钟 :
- 移除故障磁盘
- 等待 2 分钟
- 插入更换磁盘
-
这使控制器能够正确地取消注册旧磁盘,并防止热插拔识别问题。
-
-
- 验证更换后状态:
从 DD-CLI # disk show state
-
- DDSM >硬件 >存储 >磁盘
示例: DD-CLI:
-
-
sysadmin@DD# disk show state Enclosure Disk 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 --------- ---------------------------------------------- 1 . . . 2 . . . . . . . . . . . . . . s 3 . . . . . . . . . . . . . . s 4 . . . . . s . . . . . . . . . --------- ----------------------------------------------
-
-
更换的磁盘将变为 备盘,重建的磁盘将恢复使用状态。
- 对更换问题进行故障处理。
如果新磁盘显示为 未知:
-
- 运行命令
# disk rescan - 从以下位置验证磁盘的状态
DD-CLI # disk show state
- 运行命令
如果新磁盘报告 为故障
-
- 运行命令
# disk rescan - 验证驱动器的状态
DD-CLI # disk show state - 如果仍然 (F)问题,请从以下位置运行此命令
DD-CLI: # disk unfail <encl.disc>
- 运行命令
例如: # disk unfail 5.6
如果确认磁盘状态为OK(正在使用或备用),请清除任何相关警报:
-
- 从
DD-CLI # alerts clear alert-id <alert-id>
- 从
추가 정보
参考:
多个磁盘故障?
如果您在短时间内(几天到
几周)遇到三个或更多磁盘故障,这可能指示存在系统性问题(例如,多路径或固件错误),而不是单个磁盘故障。
这可能需要进一步调查,生成支持包并联系支持人员
해당 제품
Data Domain문서 속성
문서 번호: 000043773
문서 유형: Solution
마지막 수정 시간: 07 7월 2026
버전: 18
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.