DPA: DPA Agent installed on NetWorker is not registered with DPA Application Server

摘要: This article explains the workaround when the DPA Agent installed on NetWorker is not registered with the DPA Application Server.

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症状

DPA Agent is installed locally on the NetWorker server, but not registering with the DPA Application server. Agent logs have the following error messages.

ERR      5508.7112     20160530:160845         agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
WARN     5508.7112     20160530:161118         agent.config - registerAgentProcess(): Missing result in NULL

Communication from the DPA Application server and the DPA agent is working fine. Ping, nslookup from Application to agent and conversely works fine.

Manually put the agent in debug mode and grabbed the debug logs while agent tries to registers with the app server. Reviewed the logs and found that there was a hardware firewall (Internet proxy) was present.

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原因

This is an Environmental issue. DPA is working as designed.

To identify if a proxy is configured, open the command prompt with administrative privileges and run the following command "netsh winhttp show proxy."

If the proxy server is not configured, the output is shown as in screenshot below:
netsh winhttp show proxy command output

 

解决方案

Engage the local system System or Network Administrator to modify the rules and parameters configured for the firewall or proxy settings to allow the communication from the DPA Agent server to the Application server.

Another workaround which could be applied is to remove the proxy settings configured on the server. Follow the below steps to remove the proxy server settings:

  1. Stop the agent services on the server.
  2. Open the command prompt with administrative privileges.
  3. Run the command "netsh winhttp show proxy" to verify again if the proxy server is listed or not.
  4. If listed, run the command "netsh winhttp reset proxy." This removes the proxy settings configured on the server.
  5. Start the agent service back again and check the agent logs if it is registered successfully with the DPA Application server.

If the above steps did not resolve the issue. Contact EMC Technical Support for assistance

 

受影响的产品

Data Protection Advisor
文章属性
文章编号: 000054817
文章类型: Solution
上次修改时间: 29 7月 2025
版本:  4
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