DPA: DPA-agent installert på NetWorker er ikke registrert med DPA Application Server
摘要: Denne artikkelen forklarer løsningen når DPA-agenten installert på NetWorker ikke er registrert med DPA Application Server.
症状
DPA-agenten installeres lokalt på NetWorker-serveren, men registreres ikke på DPA-applikasjonsserveren. Agentlogger har følgende feilmeldinger.
ERR 5508.7112 20160530:160845 agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
WARN 5508.7112 20160530:161118 agent.config - registerAgentProcess(): Missing result in NULL
Kommunikasjon fra DPA-applikasjonsserveren og DPA-agenten fungerer som den skal. Ping nslookup fra applikasjon til agent og omvendt fungerer fint.
Sett agenten manuelt i feilsøkingsmodus og hentet feilsøkingsloggene mens agenten prøver å registrere seg på appserveren. Loggene ble gjennomgått og fant ut at det var en maskinvarebrannmur (proxy) til stede.
<td class="contentData"> You must be authenticated to access this URL. </td> </tr> <a href="http://******************/Information%20Security%20Noticeboard/Information%20Security%20Policies%20and%20Procedures/IMS-ITM-PY-00005%20(Internet%20Use%20Policy)-V5.0.pdf">******** Internet Browsing Policy Click here for review</a> </td> </tr> <td class='helpDeskData' background='/mwg-internal/de5fs23hu73ds/files/default/img/bg_navbar.jpg'> For assistance, please contact your system administrator. </td> </tr> <td class='footData'> generated <span id="time">2016-05-30 16:22:05</span> by New ****** Web Gateway <br />
原因
Dette er et miljøspørsmål. DPA fungerer som den skal.
For å identifisere om en proxy er konfigurert, åpne ledeteksten med administrative rettigheter og kjør følgende kommando "netsh winhttp show proxy."
Hvis proxy-serveren ikke er konfigurert, vises utdataene som i skjermbildet nedenfor:
解决方案
Engasjere det lokale systemsystemet eller nettverksadministratoren til å endre reglene og parameterne som er konfigurert for brannmuren eller proxy-innstillingene for å tillate kommunikasjon fra DPA Agent-serveren til applikasjonsserveren.
En annen løsning som kan brukes, er å fjerne proxy-innstillingene som er konfigurert på serveren. Følg trinnene nedenfor for å fjerne proxy-serverinnstillingene:
- Stopp agenttjenestene på serveren.
- Åpne ledeteksten med administrative rettigheter.
- Kjør kommandoen "
netsh winhttp show proxy" for å bekrefte igjen om proxy-serveren er oppført eller ikke. - Hvis den er oppført, kjører du kommandoen "
netsh winhttp reset proxy." Dette fjerner proxy-innstillingene som er konfigurert på serveren. - Start agenttjenesten på nytt, og kontroller agentloggene om den er registrert med DPA-applikasjonsserveren.
Hvis trinnene ovenfor ikke løste problemet. Kontakt EMC teknisk støtte for å få hjelp