VxRail : La création d’une machine virtuelle peut échouer car l’agent ne parvient pas à récupérer les options de création de machine virtuelle à partir de l’hôte
Résumé: La création d’une machine virtuelle peut échouer car l’agent ne parvient pas à récupérer les options de création de machine virtuelle à partir de l’hôte. Cela se produit lorsqu’un administrateur ne parvient pas à se connecter directement à l’hôte ESXi ou à le gérer sous vCenter Server. ...
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
vCenter Server affiche l’erreur suivante :
Virtual machine creation may fail because agent is unable to retrieve VM creation options from the host.
Avertissement : si LACP est configuré sur le réseau vSAN, ne redémarrez pas les agents de gestion sur les hôtes ESXi exécutant vSAN.
- Le redémarrage des agents de gestion peut avoir un impact sur toutes les tâches en cours d’exécution sur l’hôte ESXi au moment du redémarrage.
- Vérifiez s’il y a des problèmes de stockage avant de redémarrer l’hôte
daemon hostdservice ouservices.sh.
Cause
Les agents ou services sur l’hôte ESXi ont peut-être été interrompus.
Résolution
Pour résoudre ce problème, suivez l’une des procédures suivantes :
1. Redémarrezles agents de gestion sur l’hôte ESXi à l’aide de l’interface DCUI (Direct Console User Interface).
- Connectez-vous à la console de votre hôte ESXi.
- Appuyez sur F2 pour personnaliser le système.
- Connectez-vous en tant qu’utilisateur root.
- Utilisez les flèches haut/bas pour accéder à Troubleshooting Options, puis sélectionnez Restart Management Agents.
- Appuyez sur Entrée.
- Appuyez sur F11 pour redémarrer les services.
- Au redémarrage du service, appuyez sur Entrée.
- Appuyez sur Échap pour vous déconnecter.
Remarque : vous pouvez également redémarrer les services à l’aide du client hôte. Dans le client hôte, sélectionnez Host, puis Manage > Services, puis sélectionnez le service à redémarrer.
2. Redémarrez les agents de gestion dans ESXi à l’aide du shell ESXi ou de SSH :
- Connectez-vous au shell ESXi ou à SSH en tant qu’utilisateur root. Pour activer le shell ESXi ou SSH, voir Utilisation du shell ESXi dans ESXi 6.x, 7.x et 8.x (2004746) (en anglais).
- Redémarrez le processus de l’hôte ESXi et les services vCenter Agent à l’aide des commandes suivantes :
/etc/init.d/hostd restart /etc/init.d/vpxa restart
Attention :
- Si le protocole LACP est activé et configuré, ne redémarrez pas les services de gestion à l’aide de
services.sh. Au lieu de cela, redémarrez les services indépendants à l’aide de/etc/init.d/module restart. - Si le problème n’est pas résolu et que vous redémarrez tous les services qui font partie de
services.sh, prenez un temps d’arrêt avant de passer au script. - Si NSX est configuré dans l’environnement, n’exécutez pas la commande
/sbin/services.sh restartcar cela redémarre tous les services sur l’hôte ESXi. - Si vous devez redémarrer les agents de gestion sur l’hôte ESXi, redémarrez
vpxa,host.detfdmindividuellement. - Si vous devez également exécuter la commande
/sbin/services.sh restartcomme le redémarrage de chaque agent de gestion ne fonctionne pas, migrez toutes les machines virtuelles hors de l’hôte ESXi et mettez l’hôte en mode maintenance si possible. - Si vous n’êtes pas sûr que NSX for vSphere est installé sur un hôte ESXi, exécutez la commande suivante pour le vérifier :
esxcli software vib list --rebooting-image | grep esx-*
- Recherchez les VIB suivants pour déterminer si NSX est installé sur l’hôte ESXi :
vsip-esx esx-vxlan
- Si vous utilisez des graphiques partagés dans un environnement View (VGPU, vDGA, vSGA), n’utilisez pas
services.sh. Cela arrête lexorgService responsable des graphismes au niveau du système d’exploitation invité. En déconnectant les cartes graphiques du système d’exploitation invité, vous provoquez le blocage de la charge applicative VDI qui utilise les cartes graphiques partagées. Vérifiez que vous utilisez une carte graphique partagée pour redémarrer uniquementhostdetvpxasi vous n’êtes pas en mode maintenance.
Pour plus d’informations, voir l’article suivant de la base de connaissances VMware : Redémarrage des agents de gestion dans ESXi (1003490) (en anglais)
Informations supplémentaires
Reportez-vous à cette vidéo :
Vous pouvez également visionner cette vidéo sur YouTube .
Produits concernés
VxRail, VxRail Appliance FamilyProduits
VxRail SoftwarePropriétés de l’article
Numéro d’article: 000057281
Type d’article: Solution
Dernière modification: 05 févr. 2025
Version: 12
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.