NetWorker NVP vProxy: Backups fail to open DD Boost connection to the Data Domain host

Summary: After a Data Domain IP change, Virtual Machine (VM) backups using NetWorker vProxy fail with "Failed to open DD Boost connection to Data Domain host."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The IP address of the target Data Domain System was changed.

The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance. The virtual machine (VM) backups were working as expected and then started failing to open a ddboost connection to the Data Domain device. The NetWorker Server and vProxy Appliance can properly resolve (short name, Fully Qualified Domain Name (FQDN), and IP address) the Data Domain system. 
YYYY-MM-DDTHH:MM:SSZ ERROR: [@(#) Build number: ##] Failed to open DDBoost connection to DataDomain host "DATA_DOMAIN_FQDN": [5037] [ 2562] [140217763735296] Day Month Year HH:MM:SS

Cause

The vProxy daemon's cached the old Data Domain system IP address.

Resolution

Restart the vProxy daemon's to clear old Data Domain IP address from cache.
 

  1. Log in to the vProxy through an SSH client (PuTTy) and switch to the root account: 
sudo su -
  1. Ensure the vProxy can ping the Data Domain's new IP address: 
ping -c 4 DATA_DOMAIN_IP_ADDRESS
  1. Ensure the vProxy can resolve the Data Domain's new IP address and FQDN:
nslookup DATA_DOMAIN_FQDN
nslookup DATA_DOMAIN_IP_ADDRESS
  1. Reload the vProxy services:
systemctl daemon-reload
systemctl restart vbackupd.service

Optionally you can reboot the vProxy host instead: 

reboot

  1. Re-run the VM backup job.

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000172662
Article Type: Solution
Last Modified: 28 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.