Dell Unity : Bilan de santé préalable à la mise à niveau : check_if_user_root_fs_has_enough_space_1 (corrigible par Dell)

Summary: Lors de l’exécution d’un bilan de santé préalable à la mise à niveau (PUHC) sur le code Unity OE 5.1 ou version ultérieure, il peut signaler une erreur : dm ::check_if_user_root_fs_has_enough_space_1 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L’exécution d’un PUHC sur le code Unity OE 5.1 ou version ultérieure peut échouer avec l’erreur suivante :

check_if_user_root_fs_has_enough_space_1

Dans le primary_sp/nas/log/check_health.<date>.log fichier, il y a deux erreurs connues :

1) Hôte inconnu :

Data Movers: Check if user root fs has enough space
Command failed:
     * Command: /nas/bin/.server_config nas server -v "df"
     * Command output: Error 4023: nas : unknown host
     * Command exit code: 2
Action : Escalate this issue through your support organization.
     Provide this output in the escalation.
ERROR_CODE=dm::check_if_user_root_fs_has_enough_space_1|Error|/nas/bin/.server_config  nas server  -v  "df"|Error 4023: nas : unknown host
|2


2) Erreur d’analyse XML :

-------------------------------------Errors-------------------------------------
Data Movers: Check if user root fs has enough space
Command failed:
         * Command: /nas/bin/.server_config MMCSMKPACS -v "df"
         * Command output: MMCSMKPACS : commands processed: 1
Action : Escalate this issue through your support organization.
Provide this output in the escalation.
ERROR_CODE=dm::check_if_user_root_fs_has_enough_space_1|Error|/nas/bin/.server_config nasserver -v "df"|nasserver : commands processed: 1 <<<
XML parsing error: EOF looking for CDATA section end [Ln: 99, Col: 15]
XML::Simple called at /nas/lib/DartCmd.pm line 366.
for the document:
<?xml version="1.0"?>
<MAC_RESPONSE ID="client: 1" REQUEST_ID="1">
<MAC_COMMAND_RESPONSE COMMAND_ID="1" VDM="3">
<CFGCMD COMMAND="df">
<RAW_OUTPUT>

Cause

Avant le code Unity OE 5.1, un espace « » était un caractère valide dans le nom du serveur NAS.
Les noms de serveur NAS contenant un espace de caractère passeraient le contrôle PUHC sur les versions antérieures à Unity OE 5.1. 
Pour le code Unity OE 5.1 et versions ultérieures, un espace dans le nom du serveur NAS est considéré comme un caractère non valide et n’est pas pris en charge. 

L’exécution du PUHC sur le code Unity OE 5.1 ou ultérieur échoue avec l’erreur Error : <pre class="> check_if_user_root_fs_has_enough_space_1 si le nom d’un serveur NAS actuel contient un espace.
La tentative de création d’un serveur NAS avec un espace dans le nom échoue sur le code Unity OE 5.1 et versions ultérieures.  Capture d’écran d’un nom de serveur NAS illégal contenant un espace
Capture d’écran de l’erreur générée lors de la tentative de création d’un serveur NAS avec un espace dans le nom
 XML parsing error: EOF looking for CDATA section end [Ln: 99, Col: 15]
A CDATA section starts with "<![CDATA[" and ends with "]]>".
<![CDATA[......]]>
Looks like CDATA EOF parsing issue.

Resolution

Dans l’exemple ci-dessus, le nom du serveur NAS « nas server » n’est pas valide et entraînera l’échec du bilan de santé préalable à la mise à niveau. Renommez le serveur NAS pour supprimer l’espace non valide, puis exécutez à nouveau le bilan de santé préalable à la mise à niveau.

Si le problème persiste après avoir renommé le serveur NAS, ouvrez un ticket de support et consultez cet article de la base de connaissances.

Affected Products

Dell EMC Unity, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Article Properties
Article Number: 000219186
Article Type: Solution
Last Modified: 12 ديسمبر 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.