SourceOne Email management: Searching on ElasticSearch indexes shows the error: Query service unable to start the search process.
Summary: SourceOne Email management: Searching on ElasticSearch indexes shows the error: Query service unable to start the search process.
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Symptoms
A user searching on ElasticSearch indexes using Websearch or Discovery Manager gets the error: Query service unable to start the search process
User is searching on ElasticSearch indexes and receives the error depending of the date range used in the search parameter or selected mapped folder. Some date ranges or mapped folder may work with no issues.
The Indexes affected are shown in the error shown in the Websearch or Discovery Manager interface.
The following error can be seen in the ExJbQuery log of the server performing the search:
CoExESQueryPlugIn::CreateSearchAlias|ERROR|System call failed. (0x86040100) Bound to unknown type. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239).CExElasticsearchClient::CreateAlias]
CoExESQueryPlugIn::CreateSearchAlias|ERROR|Failure building search alias. Error: 0x80028027|CoExESQueryPlugIn.cpp(2822)
CoExESQueryPlugIn::BuildQuery|ERROR|System call failed. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783).CoExESQueryPlugIn::CreateSearchAlias] >System call failed. (0x86040100) Bound to unknown type. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239).CExElasticsearchClient::CreateAlias] |CoExESQueryPlugIn.cpp(601)|
CoExAsQuery::ExecuteFullText|ERROR|System call failed. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(449).CoExESQueryPlugIn::ExecuteQuery] >System call failed. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783).CoExESQueryPlugIn::CreateSearchAlias] >System call failed. (0x86040100) Bound to unknown type. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239).CExElasticsearchClient::CreateAlias] |CoExAsQuery.cpp(924)
CExQueryThread::ExecuteInThread|ERROR|Search failed to execute: (0x80028027)|ExQueryThread.cpp(315)
Cause
The issue is caused because one or more ElasticSearch index sets included in the search is missing in the ElasticSearch cluster so the JBQuery service cannot start the search.
Checking the status of the affected index in the SourceOne console may not reflect the correct status. For example, it may appear as available despite being unavailable in the ElasticSearch cluster.
Enabling Verbosity of the EXJBquery we can see the following event. Note that this is a informational event.
Checking the status of the affected index in the SourceOne console may not reflect the correct status. For example, it may appear as available despite being unavailable in the ElasticSearch cluster.
Enabling Verbosity of the EXJBquery we can see the following event. Note that this is a informational event.
CExJSONDocument::Initialize|VERBOSE| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing]","status":404}>|CExJSONDocument.cpp(124)
Resolution
User can try to "Rebuild" the affected index shown in the Discovery Manager or Websearch interface, using the SourceOne console. That will recreate the index in ElasticSearch cluster.
If the user wants to check if there are any other indexes missing in the ElasticSearch, two methods can be used.
Method 1
Enable Index Validation and configure it using Mode 1.
Run a manual or scheduled scan on all the ElasticSearch Archive folders.
Check and fix the errors in the console running a "Rebuild"
Note: Refer to the "SourceOne Administration guide" for instructions how to use "Index Validation"
Method 2
Enable Verbosity of the EXJBquery service.
Perform a search in Websearch or DM including all the ElasticSearch mapped folders.
The search should not include any date range so it will search in all the ElasticSearch index sets.
If an error "Query service unable to start the search process" is shown in the Websearch console you will need to find out which indexes are affected.
Check under Operations/Job Management which server ran the search.
Check for the following event in the ExJBQuery.log file:
If the user wants to check if there are any other indexes missing in the ElasticSearch, two methods can be used.
Method 1
Enable Index Validation and configure it using Mode 1.
Run a manual or scheduled scan on all the ElasticSearch Archive folders.
Check and fix the errors in the console running a "Rebuild"
Note: Refer to the "SourceOne Administration guide" for instructions how to use "Index Validation"
Method 2
Enable Verbosity of the EXJBquery service.
Perform a search in Websearch or DM including all the ElasticSearch mapped folders.
The search should not include any date range so it will search in all the ElasticSearch index sets.
If an error "Query service unable to start the search process" is shown in the Websearch console you will need to find out which indexes are affected.
Check under Operations/Job Management which server ran the search.
Check for the following event in the ExJBQuery.log file:
CExJSONDocument::Initialize|VERBOSE| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing]","status":404}>|CExJSONDocument.cpp(124)|Job Id: 455555; Activity Name: Search_2_8_2019_10_33_22_8240;
Note: Tracing needs to be enabled to see the entry above.
Rebuild the index sets indicated in the log entry.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000055957
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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