Connectrix MDSシリーズ:インストールが完了しませんでした。リターン コード0x40930039(アップグレードの失敗による中止)
Summary: 8.4(2e)へのアップグレード後のインストール エラー メッセージ: インストールに失敗しました。リターン コード0x40930039(アップグレードの失敗による中止)。
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Symptoms
show install all status Need to perform cleanup of failed upgrade. System is ready to continue. Successfully started the installer:<Fri Feb 4 10:28:01> <Fri Feb 4 10:28:04> Install has failed. Return code 0x40930039 (aborting due to failed upgrade). Please identify the cause of the failure and try 'install all' again. This is the log of last installation.問題が疑われる CSCvi51088 (KB #000060490)。IPドメイン検索を無効にして、8.4(2e)を再インストールしようとしましたが、ISSUは再び失敗しました。
show install all status [....] Install is in progress, please wait. <Mon Feb 20 19:22:15> Performing runtime checks. -- SUCCESS <Mon Feb 20 19:22:16> <Mon Feb 20 19:22:16> Setting boot variables. -- FAIL. <Mon Feb 20 19:22:19> <Mon Feb 20 19:22:19> Resetting boot variables. Please wait. -- FAIL. <Mon Feb 20 19:22:20> <Mon Feb 20 19:22:20> Install has failed. Return code 0x4093000C (Setting boot variables failed). Please identify the cause of the failure and try 'install all' again. This is the log of last installation.起動変数が設定されていません。
switch (config)# show boot Current Boot Variables: kickstart variable not set system variable not set Boot POAP Disabled No module boot variable set Boot Variables on next reload: kickstart variable not set system variable not set Boot POAP Disabled No module boot variable setBootflashは消費を表示しますが、bootflashがアンマウントされているため、コンテンツ ファイルは表示されません。
switch (config)# dir Usage for bootflash:// 54325248 bytes used 365105152 bytes free 419430400 bytes total switch (config)# dir bootflash: Usage for bootflash://sup-local 54325248 bytes used 365105152 bytes free 419430400 bytes totalコマンド「show version」には、起動変数が一覧表示されます。「show version」出力から起動変数を設定しようとしましたが、次のエラーが表示されました。
Software BIOS: version 2.1.18 loader: version N/A kickstart: version 8.4(2e) system: version 8.4(2e) BIOS compile time: 04/06/20 kickstart image file is: bootflash:///m9100-s5ek9-kickstart-mz.8.4.2e.bin kickstart compile time: 10/24/2022 12:00:00 [10/07/2022 02:13:28] system image file is: bootflash:///m9100-s5ek9-mz.8.4.2e.bin system compile time: 10/24/2022 12:00:00 [10/07/2022 03:32:47] switch (config)# boot kickstart bootflash:m9100-s5ek9-kickstart-mz.8.4.2e.bin Performing image verification and compatibility check, please wait.... Can not open the image. Return code 0x80A30002 (No such file or directory). switch (config)# boot system bootflash:m9100-s5ek9-mz.8.4.2e.bin Performing image verification and compatibility check, please wait.... Can not open the image. Return code 0x80A30002 (No such file or directory).コマンド「copy running-config startup-config」は正常に動作します。コマンド「copy r s」はRAM上で実行されているconfigに関連していますが、RAMはスイッチの機能を継続するため、スイッチ上のイメージでは関連していません。running-configを外部サーバーに保存することもできます。
Cause
上記の起動変数の障害は、ブートフラッシュに画像が欠落しているために発生しているようです。エラー コード0x80A30002同じ理由で(このようなファイルまたはディレクトリがない)と記載されています。ブート変数がないことを示します。
ここでのロジックは、ローダー プロンプトのスイッチがNVRAMを調子、ブート変数(見つからなかった)を取得することです。ストレージが不揮発性であるため、フラッシュの問題が疑われる。
NVRAMから起動変数を取得すると、スイッチはブートフラッシュを調子、イメージを取得します。これは再び見つからなかったため、ブートフラッシュの問題も疑われます。
進行中のファイル転送プロセスには影響がないため、構成は外部(ファイル サーバー)にコピーされました。外部サーバーからイメージをコピーし、ブートフラッシュに保存して起動変数を設定した場合でも、ハードウェアに依存することはできません。これはハードウェアの問題です。
ここでのロジックは、ローダー プロンプトのスイッチがNVRAMを調子、ブート変数(見つからなかった)を取得することです。ストレージが不揮発性であるため、フラッシュの問題が疑われる。
NVRAMから起動変数を取得すると、スイッチはブートフラッシュを調子、イメージを取得します。これは再び見つからなかったため、ブートフラッシュの問題も疑われます。
進行中のファイル転送プロセスには影響がないため、構成は外部(ファイル サーバー)にコピーされました。外部サーバーからイメージをコピーし、ブートフラッシュに保存して起動変数を設定した場合でも、ハードウェアに依存することはできません。これはハードウェアの問題です。
Resolution
- スイッチ(部門スイッチ)を再起動すると、ブート フラッシュのマウントに役立ちます。システムが起動すると、ダイレクター クラス スイッチがある場合は、事前に定義されたすべてのパーティションがスイッチまたはシステム スイッチオーバーにマウントされます。
- スイッチを交換し、保存されたバックアップから構成をリカバリーします。
Affected Products
Connectrix MDS-9148SArticle Properties
Article Number: 000212058
Article Type: Solution
Last Modified: 27 May 2025
Version: 6
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