SourceOne Email Management: Unable to access EMC SourceOne Web Search page when using Network Load Balancer (NLB) Alias after SSL setting was removed from Internet Information Server

Summary: Unable to access EMC SourceOne Web Search page when using Network Load Balancer (NLB) Alias after SSL setting was removed from Internet Information Server

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Users will not be able to use NLB alias address to access Web search after removal of SSL from the EMC SourceOne Search web/worker server

When logging into Web Search using an NLB  alias name, the expected Search login page is presented, however once credentials are provided, the resulting browser window shows a blank page with an error as "An error has occurred"

Also, during troubleshooting and run various running web traces, some other  different issues were found:
WebForm_DoPostBackWithOptions

And other with SCRIPT70 - browser tools.library.js permission denied

 

Cause

Sticky session, also referred to as Server Affinity, was not configured on the NLB solution/appliance.

Resolution

The issue is resolved after configuring sticky sessions. Involve NLB team to verify if server affinity (also referred to
as sticky sessions) are configured.

Additional Information

Check the details in install guide for the below:

When using a network load balancer, you must configure server affinity (also referred to
as sticky sessions) 
to ensure that a Web browser s requests are handled by the same
Search server instance throughout the duration of the user s session.


It is very important that the NLB has "Session Affinity", sometimes referred to as "Sticky Sessions" enabled. This NLB setting ensures that once your browser is serviced from a Search web server, all subsequent requests go back to that Search web server. If subsequent requests from a browser are re-routed to another Search server, the User Interface cannot function properly.

Affected Products

SourceOne Email Management

Products

SourceOne Email Management
Article Properties
Article Number: 000064362
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  4
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