ECS: GeoDrive Context menu unavailable in Windows Explorer

Summary: GeoDrive Context menu unavailable in Windows Explorer

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When browsing the GeoDrive Folder and highlighting a file and folder, the GeoDrive Menu is missing from the list:
When browsing the GeoDrive Folder and highlighting a file and folder, the GeoDrive Menu is missing from the list 

Cause

This usually happens when security software (McAfee) is blocking the GeoDrive explorer extension from being added to Windows Explorer.
To verify, pause your current security software and restart Windows Explorer using Task Manager:

After this the GeoDrive Menu should be available:


After this the GeoDrive Menu should be available 

Resolution

Allow the explorer extension in your security software to allow adding to Windows Explorer.
DLL which can be blocked is named: "atemc_shell.dll"

Affected Products

GeoDrive for Windows

Products

GeoDrive for Windows, ECS Appliance, ECS Appliance Hardware Gen2 U-Series, Elastic Cloud Storage
Article Properties
Article Number: 000040069
Article Type: Solution
Last Modified: 30 May 2025
Version:  5
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