NetWorker: Filesystem Backup Fails After Client Upgrade When Using VSS

Summary: After upgrading the NetWorker Client, filesystem backups fail when Volume Shadow Copy Service (VSS) is enabled. The issue is related to the NetWorker installation path not being correctly located during the VSS initialization process. ...

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Symptoms

  • Filesystem backups fail only when VSS is enabled.
  • Backups complete successfully when VSS is disabled.
  • The following errors appear in the debug logs:
    save-D3 Unable to find NetWorker install directory.
    save-D9 PopulateSupportedWriterList() Exit.
    save: Cannot back up the volume save set because the initialization of VSS did not succeed.
    
  • All VSS writers are in a stable state.
  • No shadow copies are present.
  • Manual VSS shadow creation works at the OS level.
  • No VSS-related errors are found in the Windows Event Viewer.

Cause

During a VSS-enabled backup, NetWorker attempts to retrieve the list of supported writers to process include/exclude component lists.

The failure occurs because the NetWorker installation directory cannot be located, causing the VSS initialization to fail. 

Resolution

Repair the NetWorker Client installation:

  • If the issue occurs on a standard client, perform a repair of the NetWorker Client package.
  • If the issue occurs on the NetWorker Server (added as a client), perform a repair of the full NetWorker installation package.

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000381651
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  1
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