VxRail: Помилка розгортання кластера на етапі перевірки через помилку "Наданий pnic vmnic4 не існує в хості"

Summary: У цій статті пояснюється проблема під час розгортання кластера з картами NIC 4x25G або 4x10G, яка не вдається через вимкнення LOM на iDRAC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Розгорнути кластер з картками NIC 4x25G або 4x10G, перевірка не пройшла з помилкою:

The provided pnic vmnic4 does not exist in host

 

Перевірте dayone.log менеджера VxRail.

"2023-07-03 09:42:36,726" microservice.nano-service "2023-07-03T09:42:36.204582606Z stdout F 2023-07-03 09:42:36,204 [ERROR] <Dummy-397:140103318611016> validator.py execute() (90): Validation errors: errors=[\{'type': 'THOROUGH-VALIDATOR', 'field': 'network.vds.nic_mappings', 'code': 'E3100_VAL_60', 'placeholders': ('vmnic4', '*******'), 'message': 'The provided pnic vmnic4 does not exist in host *******.'}, \{'type': 'THOROUGH-VALIDATOR', 'field': 'network.vds.nic_mappings', 'code': 'E3100_VAL_60', 'placeholders': ('vmnic5', '*******'), 'message': 'The provided pnic vmnic5 does not exist in host *******.'}]"

 

Cause

При розгортанні кластера з високошвидкісними картами NIC 4x25G або 4x10G, в залежності від різних моделей серверного обладнання, VxRail очікує нижче два допустимих сценарії NIC-карти:

  1. vmnic0 і vmnic1 відображаються на LOM, vmnic2~5 — на високошвидкісні карти NIC.
  2. vmnic0 зіставлено з LOM, а з vmnic1~4 — з високошвидкісними картками NIC.

Якщо LOM вимкнено на iDRAC, ESXi виявляє лише високошвидкісні порти NIC карти та відображає vminc0~3 на ці порти, тому перевірка розгортання кластера не вдається під час перевірки vmnic4 або vmnic5, або обох.

 

Resolution

  1. Увійдіть в інтерфейс iDRAC UI

  2. Вимкніть усі карти NIC (NDC/PCIE/OCP) у розділі Налаштування > конфігурації BIOS > Інтегровані пристрої>
    На iDRAC вимкніть усі відповідні мережеві адаптери

  3. Застосуйте зміни та перезавантажте iDRAC.

  4. Увімкніть усі картки NIC, які вимкнено на кроці 2 (якщо будь-які картки NIC призначені для вимкнення, залиште їх вимкненими).

  5. Переконайтеся, що мережевий NIC iDRAC увімкнено.
    Налаштування > iDRAC Підключення Параметри > мережі
    >>Увімкнути NIC = Увімкнено
    Вибір NIC = Виділено
    Перевірте налаштування iDRAC після зміни

  6. Застосуйте зміни та перезавантажте iDRAC.

  7. Повторіть спробу перевірки розгортання кластера.

 

Article Properties
Article Number: 000216749
Article Type: Solution
Last Modified: 31 Jul 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.