NMM backup failed to complete successfully. Internal error

Summary: The NetWorker Media Manager (NMM) backup aborts with an internal error; debug logs show failure retrieving RM Service Port Information from nsr res rmps.res, indicating the rmps.res file is missing. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Removed \nsr\res\ and \nsr\tmp folder from the client host. 

Exchange DAG backup fails with following errors:
NMM backup failed to complete successfully. Internal error

No other indications in the backup log.

Enabled Debug and ran backup (Set Application parameter: NSR_PS_DEBUG_LEVEL=9. Backup command: nsrsnap_vss_save -D9). nmm.raw shows following error:
Exch-Client123.FQDN nsrsnapagent NSR info 2 %s 1 0 111 [msg #274 vss_snapshotpriv.cpp 235 PSDBG 9] Error retrieving RM Service Port Information from /nsr/res/rmps.res

Cause

Missing \nsr\res\rmps.res file on the NMM client host.

Note: 
Error message "NMM backup failed to complete successfully. Internal error" is very generic, and can be caused due to various factors. Look for more specific messages to identify cause of failure. This KB applies where debug log shows following error:

Error retrieving RM Service Port Information from /nsr/res/rmps.res

Resolution

1. Create \nsr\res\rmps.res file and with port details and then restart "Replication Manager Client for RMAgentPS" service.

Following is a sample configuration with default ports selected.

______________

type: RM Service Ports;
Control Port: 6728;
Data Port: 6729;


______________

Affected Products

NetWorker Module for Microsoft

Products

NetWorker Module for Microsoft
Article Properties
Article Number: 000056686
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  4
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