NetWorker: Det går inte att logga in på NMC eller använda nsrlogin och ta emot: "Authentication library error: GET failed with HTTP-ERROR: 404"

Summary: Det går inte att logga in på NMC eller använda kommandot nsrlogin från CLI på NetWorker-servern. I den här kunskapsdatabasartikeln beskrivs problemet/lösningen när det också visar sig att nsr-katalogen på NetWorker-servern har 100 % kapacitet. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Det går inte att logga in på NetWorker Management Console (NMC) eller CLI med nsrlogin  
  • NetWorker-autentiseringar misslyckas med följande fel:
image

Fel i autentiseringsbibliotek: GET failed with HTTP-ERROR: Servermeddelande för 404
: Det gick inte att tolka serversvaret från json-strängserverns
meddelande: Kontrollera att servern är igång

  • NetWorker-servertjänsten (nsrd) körs:
    • Linux: ps -ef | grep nsr
    • Windows: tasklist | findstr nsr
  • Port 9090 lyssnar:
    • Linux: netstat -apno | grep 9090
    • Windows: netstat -ano | findstr 9090

Cause

Det här problemet kan uppstå under olika omständigheter:
  • Efter uppgradering/installation av NetWorker på en Windows-baserad server.
  • När /nsr-installationsplatsen har nått 100 % kapacitet.
  • authcdb-skada.
Authc-tjänsten har startat men svarar inte på autentiseringsbegäranden.

Resolution

Innan du vidtar några åtgärder för att lösa problemet kontrollerar du att installationsenheten inte har 100 % kapacitet. Om installationsenheten är full eller är nära kapacitet ökar du diskutrymmet i enlighet med det.

Authcdb måste konfigureras om.

Linux:

1. Stäng av NetWorker-tjänster:
nsr_shutdown2. Byt namn på authc-katalogen: mv /nsr/authc /nsr/authc'date -I'.bak
3. Kör authc-konfigurationsskriptet: /opt/nsr/authc-server/scripts/authc_configure.sh
Obs! Du uppmanas att konfigurera om authc-nyckellagret och NetWorker-administratörslösenordet.
4. Starta NetWorker-tjänsterna: systemctl starta networker
5. Bekräfta att NetWorker-tjänsterna har kommit igång: ps -ef | grep nsr
6. Bekräfta att port 9090-anslutningar lyckas: nsrports -t localhost -p 9090
Obs! Authc-tjänsten visas som en jsvc.exe-process för nsrtomcat+. Det här kan observeras med "ps -ef | grep jsvc"

7. Logga in på NMC eller NetWorker Web User Interface (NWUI) med networker-administratörskontot.
8. När NetWorker-funktionen har returnerats kan du ta bort den gamla authc-mappen efter eget gottfinnande.

Windows:

1. Avinstallera NetWorker.
2. Från Utforskaren i Windows går du till installationskatalogen för NetWorker och byter namn på mappen authc-server. Standardplatsen är "C:\Program Files\EMC NetWorker\nsr\authc-server"
3. Installera om NetWorker.

Obs! NetWorker-installationspaket kan hämtas från: https://www.dell.com/support/home/product-support/product/networker/drivers. Under installationen uppmanas du att skapa om NetWorker-nyckellagret och standardlösenordet för administratören.

4. Bekräfta att NetWorker-tjänsterna har kommit igång: aktivitetslista | findstr nsr
5. Bekräfta att port 9090-anslutningar lyckas: nsrports -t localhost -p 9090

Auktoriseringsprocessen anges som en java.exe-process. På fliken Information i Aktivitetshanteraren kan du identifiera processen: 
image.png

6. Logga in på NMC eller NetWorker Web User Interface (NWUI) med networker-administratörskontot.
7. När NetWorker-funktionen har returnerats kan du ta bort den gamla authc-mappen efter eget gottfinnande.

Additional Information

Om du hade Active Directory/LDAP integrerat med NetWorker måste den externa behörigheten läsas av NetWorker. Men alla behörigheter som angetts i NMC-rollerna och NSR-användargrupperna innan stegen i den här kunskapsdatabasartikeln slutfördes har behållits:

Affected Products

NetWorker, NetWorker Management Console

Products

NetWorker Family, NetWorker, NetWorker Series
Article Properties
Article Number: 000031476
Article Type: Solution
Last Modified: 20 Jun 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.