Avamar: Hyper-V 백업이 "HA VM을 가져오지 못함"과 함께 실패함

Summary: Avamar Windows Cluster Service가 클러스터링된 가상 머신을 검색할 수 없는 경우 Avamar를 사용한 Hyper-V 백업이 실패할 수 있습니다. 이 문제는 다중 프록시 구성에서 또는 클러스터 리소스가 잘못 구성된 경우에 자주 발생합니다.

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Symptoms

Hyper-V 백업이 실패하고 다음과 유사한 오류가 발생합니다.
Error <17211>: Failed to get the HA VMs from the Avamar Windows Cluster Service, Err = 80004005
Error <17203>: unable to prepare VMs for backup
Error <17179>: Failed to get the virtual machines from the Avamar Windows Cluster Service
추가 로그 항목에는 다음이 포함될 수 있습니다.
GetWmiConnection : Invalid parameter
Could not query clustered VMs. Failing multi proxy backup
Multi proxy backup did not complete successfully
데이터 세트에 지정된 하나 이상의 VM이 클러스터에서 제거되었을 수 있습니다.

Cause

다음과 같은 여러 요인이 이 문제에 기여할 수 있습니다.

  1. WMI 또는 PowerShell 서비스가 실패했거나 응답하지 않는 상태입니다.
  2. 권한 문제: Avamar Windows 클러스터 서비스에서 사용하는 계정은 Hyper-V 네임스페이스에 액세스할 수 없습니다.
  3. 잘못된 다중 프록시 구성: 여러 노드가 기본 프록시로 설정되거나 보조 노드에는 --proxy 플래그 입력 avhypervvss.cmd.
  4. 데이터 세트 구성 오류: 데이터 세트에 나열된 VM이 클러스터에 더 이상 존재하지 않습니다.

Resolution

  1. WMI 연결을 검증합니다.
    PowerShell에서 다음 명령을 실행합니다.
    • Get-WmiObject -Query "Select * From mscluster_resource where Type='Virtual Machine'" -Namespace root\mscluster

명령이 실패하면 Hyper-V 노드를 재부팅하여 WMI 기능을 복원합니다.

  1. 권한 확인:
    • 도메인 계정(Avamar Plug-in Service에서 사용)을 다음에 추가합니다.
      • 로컬 관리자
      • 각 클러스터 노드의 WinRMRemoteWMIUsers 그룹
    • 계정이 Active Directory에서 Domain Admins 의 구성원인지 확인합니다.
    1. 올바른 멀티 프록시 구성:
      • 기본 노드에만 다음이 있어야 합니다.
        • --multi-proxy=node1,node2,node3,node4
          --proxy
      • 에서 프록시 설정을 제거합니다. avhypervvss.cmd 보조 노드에서.
    2. 데이터 세트 업데이트:
      • 클러스터에 더 이상 존재하지 않는 VM을 제거합니다.
      • 장애 조치(failover) 클러스터 관리자에서 VM 상태를 확인합니다.

      Additional Information

      추가 정보

      • 클러스터 환경의 Avamar Hyper-V 백업에 적용
      • 이 단계 후에도 문제가 지속되면 로그를 수집하고 Dell 지원에 문의하십시오.

      Affected Products

      Avamar, Avamar Plug-in for Hyper-V VSS
      Article Properties
      Article Number: 000039412
      Article Type: Solution
      Last Modified: 05 Dec 2025
      Version:  5
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