DPA: Data Collection Fails with Error: No Collector is installed on the node
Summary: Data Protection Advisor (DPA) data collection fails with the error: "No Collector is installed on this node."
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Symptoms
An Object was discovered but when checking the data collection request history, a failure is observed with the error "Failed to process request: No Collector is installed on each node."

Cause
The product is functioning as designed.
There can be several causes to this issue, and it is seen when a "Local" agent is selected.
There can be several causes to this issue, and it is seen when a "Local" agent is selected.
- There is no agent installed on the server.
- There is an agent installed, but the object was discovered with an incorrect Fully Qualified Domain Name (FQDN).
- There is a network communication issue that is preventing the agent from being usable.
Resolution
Procedure:
- Check that the agent is installed and registered with the DPA Application server.
- In the DPA UI, go to Data Collection > Agents. The screen below shows the list of agents on the DPA setup.

- Check the following items:
- Ensure that the agent name in the name column of the data collection history window is also listed in the Data Collections Agents list.
- If the agent is not listed, then this is the reason for this error. If this server is not an Avamar or Data Domain, then install an agent on this server.
- If the agent is in this list, check that it matches the FQDN of the server that is having the issue with (for a local agent). In one case, the object had an agent installed but the object was discovered with the wrong FQDN. As the agents register themselves using the hostname pulled from the server, these names were different and that caused this issue. If this is your issue, then delete the object and discover it with the correct FQDN.
- If the agent is on this list and the issue is still occurring, check that port 3741 on the agent server is reachable from the DPA Application server. When there are communication issues with the agent, this error may be observed. In one case, there was a firewall on the agent server that was blocking the connection and causing this error.
Contact Dell Technical Support for more information or if assistance is required.
Article Properties
Article Number: 000054825
Article Type: Solution
Last Modified: 25 Apr 2025
Version: 4
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