ViPR SRM NetApp Collector Fails with Error "Connection result could not be retrieved"

Summary: ViPR SRM NetApp Collector fails after a few days with the error "Connection result could not be retrieved."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SRM Collector is failing to start successfully. 

This issue may appear when upgrading to SRM version 4.0.3 from SRM 3.7.x and continues at 4.1.

The NetApp collector stops every few days. NetApp Collector logs show the error below:
WARNING -- [2017-05-22 10:06:37 CDT] -- RemoteCLICommandExecutor::getConnectionResults(): Connection result couldn't be retrieved.
java.util.concurrent.ExecutionException: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Caused by: java.io.IOException: com.watch4net.apg.ssh.api.exception.SSHException: com.jcraft.jsch.JSchException: Session.connect: java.io.IOException: java.net.BindException: Address already in use (Bind failed)
Run the command ps  ef | grep 22 on the collector host that has issue. NetApp Collector uses port 22 to communicate with NetApp devices. In this case, a total 1322 TCP connections have FIN_WAIT1:
artoxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0  61369 xxx.xxx.xxx:50759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:58959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:56759    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:49959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)
tcp        0  61369 xxx.xxx.xxx:59959    xxx.xxx.xxx.xxx:2010     FIN_WAIT1   unkn-4 (82.22/0/0)

Cause

The number of TCP connections grows until it reaches the limit and it stops the collector from making new TCP connections to communicate with other devices.

Resolution

The firewall must be reset on the Primary Backend to address this issue.

  1. SSH into your Primary Backend server and then run the two commands below:
/sbin/SuSEfirewall2 off

/sbin/SuSEfirewall2  on
  1. Once completed, SSH into the NetApp Collector host and run the command below (the FIN_WAIT1 connection should not be seen anymore):
artxxxxxxx-col:~ # netstat -ano | grep 22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 127.0.0.1:40226         0.0.0.0:*               LISTEN      off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:60360    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:36621    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (45.94/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54396    xxx.xxx.xxx.xxx:22       ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:49135    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (36.91/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:37971    xxx.xxx.xxx.xxx:1521    ESTABLISHED off (0.00/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:54553    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (48.97/0/0)
tcp        0      0 xxx.xxx.xxx.xxx:41586    xxx.xxx.xxx.xxx:22       TIME_WAIT   timewait (12.27/0/0)

Affected Products

SRM
Article Properties
Article Number: 000057244
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  3
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