NetWorker: NMM 19.x SQL AlwaysOn Backup is Unresponsive and Increases Server CPU
Summary: NetWorker NMM 19.x SQL AlwaysOn backup is unresponsive and increases server CPU. The SQL backup does not proceed and appears to stop responding.
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Symptoms
Some occurrences were noted when the NetWorker server was upgraded from 18.x to 19.x.
SQL Server AlwaysOn Availability group database backups with the NetWorker Module for Microsoft (NMM) exhibit these symptoms:
- AlwaysOn backup is unresponsive. In fact, "nsrsqlsv" is launched by savefs but it never starts saving any data.
- Affects AlwaysOn (AOAG) SQL server backup over cluster client
- Database backups for the stand-alone SQL Server instances in the same AlwaysOn cluster have no issues backing up SQL database.
- NetWorker server experiences severe spikes in CPU; this may be accompanied by severe performance degradation of other running backup jobs.
Cause
Several factors in the setup may cause this behavior, and the cause may be attributed to more than one single factor.
Factors include.
- Upgrade: NetWorker Server was recently upgraded. Prior to upgrade jobs were fine. In one example, the server was upgraded from 18.x to 19.2, and SQL NetWorker Clients and NMM were also upgraded.
- Media database records: Server analysis may find many clients with no savesets, and/or inconsistent media database records for some savesets. These save sets may or may not be related to the affected SQL client.
- Clean up of media database through various methods, such as
nsrim -X -Vvolume, does not resolve the issue. - Client Index: Possible corruption of the actual client file index of the cluster client may be suspected. This last step may warrant renaming the client file index.
Resolution
The SQL Cluster client for AlwaysOn is the client that backs up the saved set which looks like MSSQL#AAG:
Example MSSQL#ALWAYS_ON_GROUP_NAME:
Perform these steps while there are no backup jobs running for the SQL Cluster client.
- Rename the client file index of the cluster client.
- Example, Rename "/nsr/index/CLUSTER_CLIENT_NAME" to "/nsr/index/CLUSTER_CLIENT_NAME.suspect."
- Run a new backup of the SQL AlwaysOn cluster client.
- A new index is generated, and a backup should succeed.
Article Properties
Article Number: 000070286
Article Type: Solution
Last Modified: 27 May 2024
Version: 4
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