NetWorker : La sauvegarde SQL AlwaysOn NMM 19.x ne répond pas et augmente le processeur du serveur
Summary: La sauvegarde NetWorker NMM 19.x SQL AlwaysOn ne répond pas et augmente le processeur du serveur. La sauvegarde SQL ne continue pas et semble cesser de répondre.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Certaines occurrences ont été notées lors de la mise à niveau de NetWorker Server de la version 18.x vers la version 19.x.
Les sauvegardes de base de données de groupe de disponibilité AlwaysOn SQL Server avec NetWorker Module for Microsoft (NMM) présentent les symptômes suivants :
- La sauvegarde AlwaysOn ne répond pas. En fait, « nsrsqlsv » est lancé par savefs, mais il ne commence jamais à enregistrer des données.
- Affecte la sauvegarde AlwaysOn (AOAG) SQL Server sur le client de cluster
- Les sauvegardes de base de données pour les instances SQL Server autonomes dans le même cluster AlwaysOn rencontrent des problèmes lors de la sauvegarde de la base de données SQL.
- Le serveur NetWorker subit de graves pics d’utilisation du processeur. Cela peut s’accompagner d’une dégradation importante des performances d’autres procédures de sauvegarde en cours d’exécution.
Cause
Plusieurs facteurs dans la configuration peuvent être à l’origine de ce comportement, et la cause peut être attribuée à plusieurs facteurs.
Les facteurs sont les suivants :
- Mise à niveau : NetWorker Server a été récemment mis à niveau. Avant la mise à niveau, les tâches fonctionnaient correctement. Dans un exemple, le serveur a été mis à niveau de la version 18.x vers la version 19.2, et les clients SQL NetWorker et NMM ont également été mis à niveau.
- Enregistrements de la base de données des supports : L’analyse de serveur peut trouver de nombreux clients sans saveset et/ou des enregistrements de base de données de supports incohérents pour certains savesets. Ces savesets peuvent être liés ou non au client SQL concerné.
- Nettoyage de la base de données des supports à l’aide de diverses méthodes, telles que :
nsrim -X -Vvolume, ne résout pas le problème. - Index client : On peut soupçonner une éventuelle corruption de l’index des fichiers client du client de cluster. Cette dernière étape peut justifier de renommer l’index des fichiers client.
Resolution
Le client de cluster SQL pour AlwaysOn est le client qui sauvegarde le saveset qui ressemble à MSSQL#AAG :
Example MSSQL#ALWAYS_ON_GROUP_NAME :
Effectuez ces étapes lorsqu’aucune tâche de sauvegarde n’est en cours d’exécution pour le client de cluster SQL.
- Renommez l’index des fichiers client du client de cluster.
- Par exemple, renommez « /nsr/index/CLUSTER_CLIENT_NAME » en « /nsr/index/CLUSTER_CLIENT_NAME.suspect ».
- Exécutez une nouvelle sauvegarde du client de cluster SQL AlwaysOn.
- Un nouvel index est généré et une sauvegarde doit réussir.
Article Properties
Article Number: 000070286
Article Type: Solution
Last Modified: 27 May 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.