NetWorker. Резервное копирование NMM 19.x SQL не отвечает и увеличивает загрузку ЦП сервера

Summary: Резервное копирование NetWorker NMM 19.x SQL AlwaysOn не реагирует и увеличивает загрузку ЦП сервера. Резервное копирование SQL не выполняется и перестает отвечать.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При модернизации сервера NetWorker с версии 18.x до версии 19.x были замечены некоторые ситуации.
При резервном копировании базы данных группы доступности SQL Server AlwaysOn с модулем NetWorker для Microsoft (NMM) проявляются следующие признаки:

  • Функция резервного копирования AlwaysOn не отвечает. На самом деле, «nsrsqlsv» запускается savefs, но он никогда не начинает сохранять какие-либо данные.
  • Влияет на резервное копирование AlwaysOn (AOAG) SQL Server через клиент кластера
  • Резервное копирование базы данных для автономных экземпляров SQL Server в том же кластере AlwaysOn не вызывает проблем с резервным копированием базы данных SQL.
  • Сервер NetWorker испытывает серьезные скачки нагрузки на ЦП; Это может сопровождаться значительным снижением производительности других выполняющихся заданий резервного копирования.

 

Cause

Такое поведение может быть вызвано несколькими факторами в установке, и причина может быть отнесена к нескольким факторам.
К факторам относятся:

  1. Модернизация NetWorker Server был недавно модернизирован. До обновления рабочие места были в порядке. В одном примере сервер был модернизирован с версии 18.x до 19.2, а также были обновлены клиенты SQL NetWorker и NMM.
  2. Записи в базе данных носителей: Анализ сервера может обнаружить много клиентов без наборов сохранений и/или несогласованные записи базы данных мультимедиа для некоторых наборов сохранений. Эти наборы сохранений могут быть связаны или не связаны с затронутым клиентом SQL.
  3. Очистка базы данных мультимедиа с помощью различных методов, таких как nsrim -X -V громкости, не решает проблему.
  4. Индекс клиента: Можно подозревать повреждение фактического индекса клиентского файла клиента кластера. Этот последний шаг может потребовать переименования индекса клиентского файла.

 

Resolution

Клиент кластера SQL для AlwaysOn — это клиент, который создает резервную копию сохраненного набора, который выглядит следующим образом: MSSQL#AAG:
Example MSSQL#ALWAYS_ON_GROUP_NAME:

Выполняйте эти действия, когда для клиента кластера SQL не выполняются задания резервного копирования.

  • Переименуйте индекс клиентского файла клиента кластера.
  • Например, переименуйте «/nsr/index/CLUSTER_CLIENT_NAME» в «/nsr/index/CLUSTER_CLIENT_NAME.suspect».
  • Запустите новое резервное копирование клиента кластера SQL AlwaysOn.
  • Будет создан новый индекс, и резервное копирование должно быть успешным.

 

Article Properties
Article Number: 000070286
Article Type: Solution
Last Modified: 27 May 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.