ECS에 내부 오류가 발생했거나 가득 차서 ECS와 Data Domain 클라우드 계층의 연결이 끊김

Summary: Data Domain 파일 시스템에서 클라우드 계층 프로파일의 연결 끊김을 보고하는 데는 여러 가지 원인이 있습니다. 연결이 끊어지면 실행 중인 데이터가 이동하고 리콜이 발생하거나 클라우드 장치가 UNAVAILABLE 상태가 되어 클라우드 정리 프로세스가 중단되거나 종료됩니다. 연결이 끊어지는 원인 중 하나는 ECS로부터 내부 500 서버 오류 수신입니다. ...

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Symptoms



Data Domain 파일 시스템에서 클라우드 계층 프로파일의 연결 끊김을 보고하는 데는 여러 가지 원인이 있습니다. 연결이 끊어지면 실행 중인 데이터가 이동하고 리콜이 발생하거나 클라우드 장치가 UNAVAILABLE 상태가 되어 클라우드 정리 프로세스가 중단되거나 종료됩니다.

클라우드 계층 장치의 연결이 끊어지는 원인 중 하나는 ECS로부터 내부 오류 'HTTP operation returned code:500'을 수신하기 때문입니다.

이런 경우 다음과 비슷한 알림 메시지가 표시됩니다.
Time: Sun Mar 1 00:08:44 2020 Alert Id: m0-3761 Event Id: EVT-CLOUD-00001 Event Message: Unable to access provider for cloud unit XXXX-XXXX-XXX. Object: CloudUnit=XXXX-XXXX-XXXX Additional Information: Cause=We encountered an internal error. Please try again. 
Due to this error , the cloud tier cleaning process may get terminated if it was in progress :
Cloud Cleaning Status --------------------- Cloud tier cleaning started on cloud unit "XXXX-XXXX-XXXX" at 2020/02/12 15:56:11 and was aborted at 2020/02/14 03:12:56. Cloud tier cleaning was aborted because cloud is unavailable Background deletion completed. 

From ddfs.info log file we may see similar error messages for the reason why the cloud tier unit got disconnected : 
02/02 10:35:58.067 (tid 0xbf47f70): ERROR: CAL cl_request_convert_httpcode_to_err:1539 - HTTP operation returned code:500, request error:We encountered an internal error. Please try again. [5009] .... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX-XXXX as UNAVAILABLE .... 02/02 10:35:58.067 (tid 0x7f77e22e2370): Fmig: fmig2_process_cal_event: XXXX-XXXX-XXXX-XXXX (path=cloud1/cp1): receiving DDR_EVENT_CAL_UNIT_UNAVAIL event .... 02/02 10:35:59.229 (tid 0x7f6ab4714fd0): INFO: Event posted: m0-1361 (21000551:553649489): EVT-CLOUD-00001: Unable to access provider for cloud unit XXXX-XXXX-XXXX-XXXX.EVT-OBJ::CloudUnit=XXXX-XXXX-XXXX-XXXX EVT-INFO::Cause=We encountered an internal error. Please try again. ... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX as UNAVAILABLE 

The 500 Internal Server Error is a general HTTP status code that means something has gone wrong on the server.
The 5xx errors are the status codes returned by the server when the server encounters an unexpected condition which prevented it from fulfilling the request from a client "the data domain system in our case " .
This error response is a generic error response that needs further investigation to get the reason for it . 

최신 AutoSupport에서 클라우드 장치 데이터 버킷에 대한 클라우드 오류 통계를 확인하여 클라우드 요청 상태를 추적할 수 있습니다.

Cloud error stats for bucket:<name of the bucket>-d0 Number of Retries : 9180 ... Number of http 400 errors : 0 Number of http 403 errors : 0 ... Number of http 416 errors : 0 Number of http 429 errors : 0 Number of http 500 errors : 10195 ----------->lots of 500 errors Number of http 503 errors : 0 ...

Cause

원인 1:
DD에서 이 오류 메시지를 받는 주요 원인 중 하나는 ECS가 완전히 가득 차서 Data Domain 장치의 수신 요청을 거부했기 때문입니다. 이 문제를 해결하려면 ECS에서 여유 공간을 확보한 후 ECS 클라우드와의 DD 연결을 복원하십시오. 

원인 2: 
ECS가 사용 중이기 때문에 수신 요청을 모두 처리할 수 없습니다.

이 오류가 발생할 수 있는 다른 원인도 있습니다. 

Resolution

해결 방법:
ECS 클라우드가 가득 찬 경우 클라우드 계층 프로파일이 Data Domain 시스템에서 통신을 복원할 수 있는 여유 공간을 확보할 때까지 Data Domain은 연결 끊김 오류 메시지를 계속 받습니다. 

해결 방법: 
ECS 클라우드가 사용 중이고 500 내부 서버 오류가 발생하는 경우 가비지 컬렉션, 데이터 이동 또는 리콜 프로세스를 동시에 실행하지 않는 것이 좋습니다. ECS 클라우드 계층에 수신되는 모든 요청을 처리할 공간을 제공하기 위해 서로 다른 시간에 실행되도록 일정을 조정합니다. 문제를 더 정확히 파악하는 데 도움이 되도록 ECS 지원에 도움을 요청하십시오. 


Additional Information

문제가 해결되지 않으면 ECS와 Data Domain 지원 모두에 대한 새 지원 케이스를 열어 이 문제를 함께 분류하십시오. 
새 Data Domain 지원 케이스를 열 때 새 지원 번들을 수집하고 업로드하십시오. 

Affected Products

Data Domain

Products

Data Domain, Data Domain Deduplication Storage Systems
Article Properties
Article Number: 000081881
Article Type: Solution
Last Modified: 11 Dec 2023
Version:  4
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