Deployment KB: AppSync: Failed to add VMAX/PowerMAX storage in AppSync console.

Summary: SMI-S provider must be installed properly in order to add VMAX storage to AppSync.

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Symptoms

Failed to add VMAX/PowerMAX storage in AppSync console.

Error message:
Error: 500 Unable to connect to SMI-S Provider on host xx.xx.xx.xx. Failed with error: Unable to connect.

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When adding VMAX/PowerMax storage in AppSync console, AppSync tries to connect to the SMI-S provider and fails with the above error message.

Cause

SMI-S provider was not installed on the management server, or Solutions Enabler was installed but the user did not complete the SMI-S provider installation by running TestSmiprovider.exe.

Resolution

The above error occurs if SMI-S Provider is not installed and configured.

To address this:
  1. Download required SMI-S/SE Version and install on the Management server.
  2. Open command prompt and go to C:\Program Files\emc\ecim\ecom\bin   
  3. Run TestSmiprovider.exe
  4. Select all defaults.
  5. Open AppSync console and add storage.
During the install of Solutions Enabler, ensure that the "Complete" option is selected from the Setup Type window of the Installation Wizard. This will ensure that SMI-S is installed.
Article Properties
Article Number: 000168564
Article Type: Solution
Last Modified: 10 Sep 2025
Version:  4
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