PowerStore: Health check fails with error: check_idc_node_reachability_failed

Summary: Health check fails with error: check_idc_node_reachability_failed

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Health check fails with error:      
The appliance primary node cannot reach the secondary node through the native VLAN. This will prevent NAS services and Intra Cluster Data network from being fully functional. Ensure that the physical switches are configured properly. (Check_icd_node_reachability_failed)
 
Unable to ping between the Intra-Cluster data (ICD) interfaces from Node A to Node B, or the opposite way, or may be able to ping between ICD interfaces but still get the error:     
check_icd_node_reachability_failed

To test (ping) connectivity between the interfaces, find the Intra-Cluster data (ICD) IP address:     
  • Run ip addr and search for icd0.
  • Also, find it in PowerStore Manager by Settings > Networking > Network IPs > ICD
Note that ICD IP addresses are ipv6. Specify that in the ping command. 
 
Example:    
  • Node A: ping -6 -I icd0 <Node B's ICD ipv6 ip address> -c 3
  • Node B: ping -6 -I icd0 <Node A's ICD ipv6 ip address> -c 3

Cause

PowerStore NAS/iSCSI network is not configured correctly.

Resolution

If the PowerStore uses FibreChannel(FC) Only configuration, properly configured Ethernet ToR switch connections are required to continue. Refer to the Dell PowerStore T and Q Networking Guide for Initial Deployment for additional details.

If unable to ping as shown above, investigate the network to determine why. 

  • Check the switches to verify the bond/vLANS are correct.
  • Check that IPv6 is enabled on the necessary interfaces.

Refer to the Dell PowerStore T and Q Networking Guide for Initial Deployment to ensure that everything is set up correctly.

Lastly, upgrade to the latest PowerStoreOS in order to clear the error.  
 

NOTE:  For additional information about Pre-Upgrade Health Check (PUHC) failure related issues, refer to the following links:

If unsuccessful and still getting the error check_icd_node_reachability_failed, contact Dell EMC Technical Support or your Authorized Service Representative, and quote this Dell Knowledge Base article ID.

Affected Products

PowerStore, PowerStore 7000T
Article Properties
Article Number: 000182257
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  8
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