VxRail: High vSAN Latency and CRC Errors on Network NIC Stats

Summary: Multiple hosts seeing high CRC errors leading to vSAN latency.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • From the Cluster > Monitor > vSAN Health: MTU checks (ping with large packet size): See article VxRail: MTU checks (ping with large packet size)
  • Host large ping test (MTU check) fails intermittently
  • High CRC errors seen on vSAN vmnics stats counters
esxcli network nic stats get -n vmnic1

 host1
 NIC statistics for vmnic1:
 Receive packets dropped: 0
 Transmit packets dropped: 0
 Total receive errors: 216001
 Receive length errors: 0
 Receive over errors: 0
 Receive CRC errors: 216001
 Receive frame errors: 0

 host2
 NIC statistics for vmnic1:
 Receive packets dropped: 0
 Transmit packets dropped: 0
 Total receive errors: 283604
 Receive length errors: 0
 Receive over errors: 0
 Receive CRC errors: 283604
 Receive frame errors: 0

 host3
 NIC statistics for vmnic1:
 Receive packets dropped: 0
 Transmit packets dropped: 0
 Total receive errors: 0
 Receive length errors: 0
 Receive over errors: 0
 Receive CRC errors: 0
 Receive frame errors: 0

 host4
 NIC statistics for vmnic1:
 Receive packets dropped: 0
 Transmit packets dropped: 0
 Total receive errors: 170796
 Receive length errors: 0
 Receive over errors: 0
 Receive CRC errors: 170796

Cause

High CRC errors are symptoms of Layer 1 issues. It could be a defective cable, SFP, or Network Interface Card (NIC).

The above stats are an indication that host1, host2, and host4 were receiving CRC (inbound) from host3, and host3 may be the source of the CRC errors causing vSAN performance issues.

Resolution

  1. To see CRC Errors increment, run command:
watch esxcli network nic stats get -n=vmnic1 | grep "Receive CRC errors"
  1. Shut down uplink to vmnic1:
esxcli network nic down -n vmnic1

Note: Ensure that there is uplink redundancy (for example vmnic0, vmnic1) before changing the link status to down state. At this point, you should see no increment in CRC errors and no vSAN latency.
 
  1. Replace SFP that is connected to vSAN uplink1 and change the uplink status to UP. Also consider replacing the cable to the uplink in the event SFP replacement did not stop the CRC errors.

Affected Products

VMWare Cloud on Dell EMC VxRail E560F, VMWare Cloud on Dell EMC VxRail E560N, VxRail 460 and 470 Nodes, VxRail Appliance Family, VxRail Appliance Series, VxRail G Series Nodes, VxRail E Series Nodes, VxRail E560 VCF, VxRail E560F VCF , VxRail E560N VCF ...

Products

VxRail E560, VxRail E560F, VxRail E560N, VxRail E660, VxRail E660F, VxRail E660N, VxRail E665, VxRail E665F, VxRail E665N, VxRail G560, VxRail G560 VCF, VxRail G560F, VxRail G560F VCF, VxRail P Series Nodes, VxRail P570, VxRail P570F, VxRail P580N , VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S Series Nodes, VxRail S570, VxRail S570 VCF, VxRail S670, VxRail Software, VxRail V470, VxRail V570, VxRail V570 VCF, VxRail V570F, VxRail V570F VCF, VXRAIL V670F, VxRail VD-4510C, VxRail VD-4520C, VxRail VE-660, VxRail VE-6615, VxRail VP-760, VxRail VP-7625, VxRail VS-760 ...
Article Properties
Article Number: 000182663
Article Type: Solution
Last Modified: 10 Sep 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.