RecoverPoint for VMs: HTML5 Plugin does not get deployed in vCenter

Summary: After completing the RecoverPoint HTML5 Plugin configuration on the Deployer page, you will not see the Plugin being deployed in vCenter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After completing the RecoverPoint HTML5 Plugin configuration on the Deployer page, you will see a successful configuration message.

Although when you look at: vCenter -> Administration -> Solutions -> Client Plug-ins, You will not see the Plugin "RecoverPoint for Virtual Machines" being deployed.

Cause

The cause for the behavior you see, is related with previous configuration made on the RecoverPoint system.

Initially, the Plugin server was configured to access 2 vCenter (not in linked mode). This configuration is not supported in RecoverPoint for Virtual Machines, if the vCenter is not in Linked Mode, you need 1 RecoverPoint Plugin server per vCenter. 

When the plug-in is unregistered from MOB, some details are left that blocks further plug-in deployments.

Resolution

In order to resolve the issue stated above, follow the below steps.
 
  1. Shutdown RecoverPoint for Virtual Machines Plugin server
  2. Access MOB https://vCenterIP/mob
  3. Click on the following hyperlinks:  Content -> ExtensionManager 
  4. Unregister extension: com.dell.recoverpoint.vc.h5plugin and com.emc.recoverpoint.vwc
  • Enter above extension names after selecting hyperlink UnregisterExtension 
       5. Go back to Home page on MOB and go to Content -> CustomFieldsManager 
       6. Review the Value field under Properties and take a note of the int value for the fields containing the name like "config.RecoverPoint_TOKEN;xxxxxxxxxxxxxxxx"
  • Go back to CustomFieldsManager and select the Method RemoveCustomFieldDef. Enter the int value for the fields reviewed in 6.
                  7. Stop vsphere-ui service
  • Access the affected vCenter using Putty or Web Console and run command: service-control --stop vsphere-ui
                  8. Delete all folders referring to RecoverPoint HMTL5 Plugin
  • Access the affected vCenter using SSH and run command: find /|egrep -i "com.dell.recoverpoint" |xargs rm -rf {} \;
                  9. Start vsphere-ui service
  • Access the affected vCenter using Putty or Web Console and run command: service-control --start vsphere-ui
                10. Start RecoverPoint for Virtual Machines Plugin server
                11. Configure Plugin from Deployer Page 
  • Access https://vRPA_Management_IP/WDM/#!/welcome
  • Select the option to Configure Plugin server
After completing all above steps, allow a few minutes for RecoverPoint Plugin to establish all necessary communications between vCenter and RPA cluster. Access RecoverPoint Plugin on vCenter, and you can see all details displayed.

Affected Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000183980
Article Type: Solution
Last Modified: 27 Sep 2023
Version:  4
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