AppSync: AppSync 4.2 Agent crashes with ucrtbase.dll as the faulting module
Summary: When AppSync 4.2 is installed users may find intermittent agent crashes. These will be characterised by intermittent loss of communication with the agent during the running of a Service Plan and a number of events will be seen in the Hosts System and Application Event logs. This issue may be seen on both Windows 2016 and 2019. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Users may experience intermittent crashes by the AppSync 4.2 or AppSync 4.2.0.1 agent. This issue can be identified by the following Symptoms.
Firstly the following error may be seen in the Events for an AppSync Service Plan:
Firstly the following error may be seen in the Events for an AppSync Service Plan:
AppSync server failed to connect to agent host: <Host Name>. Ensure the agent host is up and reachable from the AppSync server. If this is a Windows agent host, ensure AppSync Host Plug-in service is in running state.
When the the host is checked the following messages can be seen in the Host Application Event log:
03/05/2021 12:56:47 PM Information <Host Name> 1001 Windows Error Reporting Fault bucket , type 0 Event Name: BEX64 Response: Not available Cab Id: 0 Problem signature: P1: APPSYN~1.EXE P2: 4.2.0.0 P3: 602b55dd P4: ucrtbase.DLL P5: 10.0.10240.16390 P6: 55a5b718 P7: 0000000000064388 P8: c0000409 P9: 0000000000000005
Cause
This can be caused by the host system running an version of the ucrtbase.dll that is incompatible with AppSync. Or by a code bug in the AppSync Agent.
Resolution
Take the following steps to resolve this issue:
- Run all cumulative windows updates and security updates on the host and reboot the host as required.
Ensure that the ucrtbase.dll file has the below minimum versions:
For Windows server 2016, verify that minimum version of ucrtbase.dll is 10.0.14393.2097.
For Windows server 2019, verify that minimum version of ucrtbase.dll is 10.0.17763.719.
Restart the host plugin service and run the service plan again.
For Windows server 2019, verify that minimum version of ucrtbase.dll is 10.0.17763.719.
Restart the host plugin service and run the service plan again.
- If the issue is not resolved at this point a hotfix has been created for this issue. This can be acquired by opening a Service Request.
Article Properties
Article Number: 000185071
Article Type: Solution
Last Modified: 28 Feb 2022
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.