Dell Unity: Pool Expansion or Creation with Non-Unity Supported SSDs May Result in Dual SP Panic and Data Unavailability or Data loss - User Correctable
Summary: Pool expansion or creation with non-Unity supported SSDs may result in dual SP panic and data unavailability or data loss.
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Symptoms
Using non-Unity supported drives on Unity causes performance impact, data unavailability, or even data loss. If such drives are found on the array, it requires immediate attention from the customer to engage their vendor to get it resolved. The non-Unity supported SSD drive must be removed to get normal support from Dell.
The non-Unity supported SSD drives cannot be removed by normal procedures, see the resolution section below for instructions on how to remove these drives.
If a pool expansion or creation is performed with non-Unity supported SSDs, both SPs panic sequentially and cause data unavailability. After both SPs come back online, data unavailability is resolved, non-Unity supported SSDs are added into the pool on code level 5.1.x or earlier. Though the pool is still able to service I/O, the drives impact the performance and cause other issues. Furthermore, once these non-Unity supported SSDs are added into the pool, they cannot be swapped out. Later, if these drives fail, it causes data loss for the customer.
In the next formal release (5.2.x), if the customer still has non-Unity supported SSDs in the pool, the drives are proactively failed. If there is only one drive failure in an RG, the pool is degraded, if there are multiple drives failing in the same RG, the pool may be offline which leads to data loss.
The non-Unity supported SSD drives cannot be removed by normal procedures, see the resolution section below for instructions on how to remove these drives.
If a pool expansion or creation is performed with non-Unity supported SSDs, both SPs panic sequentially and cause data unavailability. After both SPs come back online, data unavailability is resolved, non-Unity supported SSDs are added into the pool on code level 5.1.x or earlier. Though the pool is still able to service I/O, the drives impact the performance and cause other issues. Furthermore, once these non-Unity supported SSDs are added into the pool, they cannot be swapped out. Later, if these drives fail, it causes data loss for the customer.
In the next formal release (5.2.x), if the customer still has non-Unity supported SSDs in the pool, the drives are proactively failed. If there is only one drive failure in an RG, the pool is degraded, if there are multiple drives failing in the same RG, the pool may be offline which leads to data loss.
Cause
Installing non-Unity SSDs into a Unity array.
Resolution
If the non-Unity supported SSDs are already added into the pool, the fastest way to alleviate this situation is to backup the data to another normal pool (or other location). After this is done, destroy the related pool, or re-init the array, then remove the non-Unity supported SSDs from the array.
If the non-Unity supported SSDs are NOT added into the pool, remove them from the array immediately to avoid this issue.
If the non-Unity supported SSDs are NOT added into the pool, remove them from the array immediately to avoid this issue.
Affected Products
Dell EMC Unity HybridArticle Properties
Article Number: 000193090
Article Type: Solution
Last Modified: 11 Oct 2023
Version: 3
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