No Video During BitLocker Pin Screen Using a WD19 or WD22 Dock with a Belkin UN-3 KVM

Summary: Learn to resolve no video on a BitLocker pin screen when using a WD19 or WD22 dock and a Belkin UN-3 KVM (keyboard, video, mouse) device.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The BitLocker pin screen may not display on a full high-definition (FHD) external display that is connected to a Belkin KVM while using a DisplayPort (DP) cable from the docking station with the laptop lid closed. This affects Belkin devices in the UN-3 family.


Affected Platforms:

  • Latitude 5320
  • Latitude 5430
  • Latitude 9420
  • Precision 3470
  • XPS 17 9700

Affected Docks:

  • WD19DCS - Dell Performance Dock
  • WD22TB4 - Dell Thunderbolt Dock

The FHD external displays show the BitLocker pin screen if either the docking station or the Belkin UN-3 KVM is disconnected. The BitLocker pin screen also displays if an FHD monitor is directly connected to the computer.

Cause

This is expected behavior due to a KVM limitation.

Resolution

There are several possible resolutions for this.

  • Type in the PIN for BitLocker during the blank screen and then press Enter.
  • When using FHD external display connected to the KVM Console Out, connect the dock to the Belkin KVM UN-3 using HDMI instead of DP.
  • Use monitors with a display resolution that is greater than 1920x1080.

Affected Products

Dell Performance Dock – WD19DCS, Latitude 5320, Latitude 9420, Latitude 5430, Precision 3470, Dell Thunderbolt Dock – WD22TB4, XPS 17 9700
Article Properties
Article Number: 000206493
Article Type: Solution
Last Modified: 05 May 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.