PowerProtect Cyber Recovery: NetWorker application recovery fails with error: Data Domain disk XYZ not in media index

Summary: NetWorker application recovery fails with an error message "Failed to run task recoverapp. Error mounting device; Error is Data Domain disk XYZ not in media index."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker application recovery using Cyber Recovery Manager fails with an error message:
Failed to run task recoverapp. Error mounting device. Error is Data Domain disk XYZ not in media index.
 
Screenshot of error message
Figure 1: Screenshot of error message

The Cyber Recovery Manager's Apps log file has the following error messages corresponding to the failure.
/opt/dellemc/cr/var/log/apps/apps.log

[2023-07-10 11:41:53.725] [DEBUG] [apps] [RecoverNetWorkerApp.go:628 NWMountDevices()] : deviceStatus.Message: Data Domain
 disk XYZ not in media index
[2023-07-10 11:41:53.725] [DEBUG] [apps] [RecoverNetWorkerApp.go:629 NWMountDevices()] : deviceStatus.OpInProg: false
[2023-07-10 11:41:53.726] [ERROR] [apps] [RecoverNetWorkerApp.go:641 NWMountDevices()] : Error mounting device. Error is Data
 Domain disk XYZ not in media index
[2023-07-10 11:41:53.726] [DEBUG] [apps] [RecoverNetWorkerApp.go:642 NWMountDevices()] : Exiting
The vault NetWorker Server's NSRDR log file has the following error message corresponding to the failure.
/nsr/logs/nsrdr.log

204591:nsrmmdbasm: Cannot run media database recovery: Action 'Media Database Recovery' refused because the server is
 currently in the 'active' state.  To run this action the server must be in the 'disaster recovery' state.

Cause

The vault NetWorker Server is in the default "active" state before starting the application recovery using Cyber Recovery Manager.

Resolution

For deployments running NetWorker 19.8 or later, ensure that the vault NetWorker Server's "Server state" in "Server Properties" is set to the "disaster recovery" state before starting the application recovery in Cyber Recovery Manager. This is detailed in the Cyber Recovery Product Guide in the Prerequisites of the "Initiating a NetWorker recovery in the Cyber Recovery UI" section.
 
Screenshot showing Server State set to Disaster Recovery
Figure 2: Screenshot showing Server State set to Disaster Recovery

Affected Products

PowerProtect Cyber Recovery, NetWorker
Article Properties
Article Number: 000215665
Article Type: Solution
Last Modified: 28 Jul 2023
Version:  2
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