The Touch Screen on Certain Dell Laptops Stops Working if you Resume from Hibernation with the Lid Closed
Summary: The following article provides information about a touch screen problem when they wake from hibernation with the lid closed. The touch screen stops working on certain Latitude and Precision laptops when this occurs. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Waking from Hibernation with the lid closed causes some touch screens to stop working
You may experience a problem where the touch screen stops working on your laptop when you resume from hibernation with the lid closed. This problem only shows when the following circumstances are met:
- You must have entered the BIOS setup screens and switched the option block sleep to enabled. (It comes default set to Disabled.)
- You enter hibernation by closing the lid of the laptop. (The same problem is not seen if you enter hibernation by using the power button or the start menu option.)
Laptops with touch screens affected by this problem:
- Latitude 3140 laptop
- Latitude 7330 laptop
- Latitude 7430 laptop
- Latitude 9330 laptop
- Latitude 9430 laptop
- Dell Pro 13 Premium
- Precision 7670 Mobile Workstation
Cause
The laptop is working as designed.
Resolution
This is what we would expect to happen if you set block sleep to enabled and then close the laptop lid to enter hibernation. You can turn the block sleep option off in the BIOS if you must be able to enter hibernation by closing the laptop lid.
Affected Products
Dell Pro 13 Premium PA13250, Latitude 3140, Latitude 7330, Latitude 7340, Latitude 9330, Latitude 9430, Precision 7670Article Properties
Article Number: 000228526
Article Type: Solution
Last Modified: 10 Jan 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.