Connectrix Brocade B-series: Unable to add switch to SCG. Error "Add product Failed: Response code: 0"

Summary: Error "Add product Failed: Response code: 0"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to add switch to SCG.

 

MI2BRDCX7-1T018:FID128:admin> scgconfig --config -serverip 10.59.x.x -port 9443 -model SWITCH-BROCADE-B-GW
SCG configuration has been updated successfully.

 

MI2BRDCX7-1T018:FID128:admin> scgconfig --add -user <username> -password ********
Add product Failed: Response code:0
Error: Backend Sync failed rc:-1

Cause

Response code:0 - This error code indicates that the switch is unable to reach the SCG server.
This can occur if the firewall is blocking traffic over port 9443 or if there is a network restriction.

Resolution

1) Verify if port 9443 is listening on SCG. 

scgdellnordpsn:~ # netstat -tunlp | grep 9443
tcp 0 0 0.0.0.0:9443 [0.0.0.0] 0.0.0.0:* LISTEN 1427/dockerd

 

2) Check with the network team if port 9443 is open between the switches and SCG gateway.
You may also try pinging the SCG IP address from the switch and conversely.

 

3) Ensure firewall is disabled.

 

Affected Products

Connectrix ED-DCX7-8B

Products

Connectrix B-Series Hardware
Article Properties
Article Number: 000261119
Article Type: Solution
Last Modified: 11 May 2025
Version:  2
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